How to lit a scene without lights of any type, nor shadows. For a cartoon look?

The idea is to texture paint everything, including the shadows. Reason why I should not have shadows from lights.
Have a look at the attached example image. Done by Martin Turner from CG Masters, in his tutorial to use Multi Layered Texture Painting. The problem today, is that he was using the Blender Internal renderer.
Could anyone provide the settings needed to achieve this look, for the render settings, and materials, and anything else?
Thank you in advance guys!

I haven’t looked at the tutorial, but with this simple workbench render setup you have shadeless textures.


For layer painting fun in 2.8+ I recommend this addon:
https://bitbucket.org/mephisto_/blender_paint_layers/downloads/

I totally forgot about Workbench!
You’re right, my imported vector drawing PNGs look better with Workbench, in terms of color and saturation.
There is only one problem, the texts I made with Inkscape (PNG with Alpha) show thin white lines around them, have a look at the attached sample.
How can I avoid it? - Here is a .blend file should you want to inspect my settings:
png-problem.blend (700.1 KB)

Thanks a lot for sharing the Paint Layers addon, very kind of you! I can’t wait to try it.

Screenshot from 2020-03-05 17-44-18

Btw, I did install the Addon, but I don’t see it. Its location is supposed to be View 3D>Tool>Layers
What does it look like? Could you send me a small screenshot? Thanks Mario

You should make sure that at least 1 pixel at the edge of the png is transparent.


The addon is not mine :slight_smile: but you can find it under layers in the texture paint tool.
paintlayers
png-problem_x2.blend (809.7 KB)

Thanks a million Mario! :slight_smile:

DPC

1 Like