How to lock same lighting to any model?

Hello. I have a problem with lighting. Just modelled one part of the roof and have made color of part number 1 as I want, It is ok for me, but If I make similar part or just rotate the part number 2 for example, part color changes dramatically. Any ideas how to keep model the roof parts in same color and lighting, I’m using eevee.

I’d assume you have some reflection/spec on, and so it’s just reflecting the white background, causing the part to look lighter in shade. Try tweaking the spec or roughness, or just turn it off completely.

1 Like

File here:
If someone has a solution or have good lighting skills in eevee, I could for work. PM

But if turn off roughness all reflections goes away, maybe I can bake this lighting and color and use on all models, just like texture?

It’s expected behavior from the principled or any PBR shader. Look around you, everything has variations in the real world.

If you are looking for a consistent colour, either turn off specular/glossy, or look at the toon shader.


Mix between diffuse and glossy, but instead of using fresnel to mix them you just use a fixed number. It’s not going to be realistic, but it might give you what you want.

1 Like

Do remember that Blender now offers the “Workbench” renderer as an option! And, for scenes like you might now be describing, it might well be a good choice to consider. Just select it in the Render tab, and see what you think.

1 Like