how to make a in game animation

Hey! I have been looking around ALOT and I havent found any tutorials that tells me how to make a ingame animation. like if i would make a thirdperson rpg and i would like to make a a walk animation or a punch animation. How do i do that?
A tutorial would bee great but I take all the help I can get :smiley:

Hey, buddy. How’s it goin’? Yeah, I’m having the same trouble. See if this (link below) won’t work for you. It’s old, and I can’t seem to get it to work, but who knows, right? :wink:

http://otothecleaner.free.fr/tutorials/LittleOTO/littleoto6/otolittle6.html

Use an armature like a skeleton…there is a very very basic YouTube tutorial on armatures made by super3boy. Search for super3boys blender armature tutorial.

Do this but on a bigger scale to your character… In the actions panel you can name the action you just posed/ animated him to do…call it something releavent such as punch or run.
Then use an action sensor to play that ingame

The blender gamekit (second edition) has an excellent very clear tute on this. I bought it from the Blender Institute, but it may have been CC licensed and put on the net. Not sure.

http://www.users.bigpond.net.au/blendage/pages/tutorials/tut8/realtimearmatures.html

Well, I’m doing something wrong, but for the life of me I can’t figure what. Either my install hates me (though I’ve tried with both 2.46 and 2.48), or I’m missing something very basic. I followed two different tutorials, including the one Rozzy posted right above, and nothing. I’ve been rigging armatures for awhile now, and the animation works fine in the 3d view, or as a rendered animation, but when I hit P, nothing happens. Maybe the armature’s moving and it’s not translating to the mesh in game engine, I don’t know.

So the following shows most of the important stuff: The Action, the Logic Blocks, the Character settings. As you can see, the mesh is bending fine in 3D view, but when I hit “P”, it’s straight as a board. Anyone can spot anything I’m doing wrong, or leaving out that might be it, please let me know. I wouldn’t be surprised if there were something totally obvious I’m missing, like a button I’ve got clicked wrong. Thanks!

(Oh, and I also tried setting the Action Actuator to “Loop End” – nothing. I also initially had it set to end at Frame 41 – no difference there, either.)

Well if im not mistaken, i see your armature is set to “Always” you should assign it to “Keyboard” and add a key like “W” to move. If not, then post your .blend file and see if any of us can help. Im not that good yet in that kinda thing but i can sure try!

Okay, here it is… would have done it last night, but too tired to find a place to host the file. :slight_smile:

I tried using the keyboard during experimentation, that didn’t work, either. It’s “Always” because I decided to follow the tutorials exactly, (oops, added an extra armature bone). In the end, I’m going to want it to work on mousedown, when the mesh character swims – the movement, the cam following it, those all work fine, but it moves like a block, instead of wriggling – but for now I just need it to work, period.

tentacles_new.blend (219 KB)

I’m thankful for whatever help anyone can offer.

EDIT: Oh, funnily enough, I’d found an older file that, when I appended the objects and actions, <did> work in GE, but when I analyzed it, it used old-style Driven Shapes – when I converted it to new style Armature modifier, it didn’t work, either.

Hey! I think you’ve hit something there! Okay, the animation won’t work in the GE for my character, so I went back to a file that I created just before I upgraded from 2.46 to 2.48, and it WORKED! So, I tried imported the new mesh to the old armature, hoping that maybe it was the armature, nothin’ doin’. It did not work. I have no idea what you are talking about when you talk of old-style shapes and new style Armature, could you educate me? Is there a way we can fix that? :eyebrowlift2:

Okay, the wroking “old style” file was from this thread:
http://blenderartists.org/forum/showthread.php?t=141286

And this was the “fixed”, working file, from that thread (courtesy of Zarnik):

/uploads/default/original/3X/1/3/13e17a925d0d53d7ee78a08416308ee21bd96479.blendd=1227062601
(Nota bene: I could not split or resize any screens on this file, for some reason, I’m guessing a version compatability thing; in order to work with it properly, I had to append the objects and actions to new file – where it did work.)

What little i know about the “old style” Driven Shapes comes from this thread:
http://blenderartists.org/forum/showthread.php?t=148431

where bjornmose said:

Looks like you have found a file with the old child parent relation for armatures.
It was used before blender had a modifier stack.
To keep compatible with old files the modifier stack plugs it in as if it was a regular modifier, thus virtual.
Today you would add a real armature modifier.

So I clicked the little button to convert it to a real modifier, and… poof. No more workie.

Any who can ensmarten me, please do.

That is not a version compatibility thing. The 3D viewport window was maximized. Press Ctrl+Down Arrow over the Blender window to return it to normal mode.

To make your animation work: You cannot use the armature modifier with the Game Engine. The only way I know of to make armatures work is to select the mesh object and then the armature together with it and press Ctrl+P to make the armature the parent of the object. Follow these steps to do this in you file:

  • Select the tentacle mesh.
  • Delete the armature modifier from the stack.
  • Press Alt+P over the 3D viewport window and select “Clear parent and keep transformation (Clear Track)”.
  • While the tentacle mesh is still selected, Shift+Right Click the armature to select it as well. It is very important for the armature to be the active object, that is, the last object selected when multiple objects have been selected.
  • Press Ctrl+P and select “Armature”, then “Don’t create groups” (you already have your vertex groups created, so don’t let Blender try to do it again or they will get messed up).

If you have followed these steps, your tentacle will now work in the Game Engine. A couple of extra notes:

  • If you look in the tentacle’s modifier stack you will now see an entry called “Armature parent deform”. It has no options but a “Make Real” button. Don’t click the “Make Real” button or the armature will stop working in the Game Engine.
  • You may already be aware of this, but SubSurf does not work in the Game Engine. You will need to apply your SubSurf modifier to see the extra geometry in your game.

aahahahahahahahahahahahahahahah! Thaaaaaaaaank yoooooouuuuuuuuuu! Ahahahahahahahahahahahaha! It woooorrrrrrrkkkeeeed! Wooohooooo! Ahahahahahahaha! Yee-haw! You’re the best dude!!! Ahahahahahahhahahahaha! :d it wooooorrrrrkkkkked!