How to make a non-reflective glass shader?

I tried the better-glass-version from Andre Price from his interior tutorial, but it is not working. There is only one chair inside the cabin but the reflection makes it look like there are more than one. And it also creates a weird reflection. Have a look:


Let me guess: You’re using a refractive shader on a no-thickness-flat-plane window? Don’t.
Never use refractive shaders on physically implausible objects. Use a transparent/glossy mix instead.

^^^ yep. What you are seeing OP is refraction, not reflection.

By modelling the glass without thickness - you have in essence filled the cab with water.

I don’t understand. I have the Glass with thickness to it. All the glasses have thickness. Here is some useful info:


Wrong guess :slight_smile:

share a sample

can you be more specific please? Sample of what?

Trash that and use a glass node and see if you get the same result (kind of looks like a piece of glass that fills the cabin). If you don’t want reflection or refraction, then set the IOR in the glass node to 1 or use a transparent node.

Sample of your problem - shader & geometry :rolleyes: … are normals OK?

That makes it even worse. The reflections and refraction shows up and when I set the IOR to 1, the glass disappears.

Normals are OK.

There is thickness.

The shader is shown in the second pic. (https://blenderartists.org/forum/showthread.php?439971-How-to-make-a-non-reflective-glass-shader&p=3251296&viewfull=1#post3251296)

Using Glass shader gives reflections and refractions and noise. I want a clear glass like this: https://i.ytimg.com/vi/99aOdRJp-JA/maxresdefault.jpg

Geometry is fine.

More info here:


If you want manual glass on thick panes, all you need to do is setup the shader manually:
Fresnel to mix between refraction shader and glossy (sharp is ok) shader. If you want to lower the reflections you just dial in a darker value. You can then mix in a transparency shader after that using LightPath/isShadowRay to eliminate it casting shadows, very useful if caustics is turned off and/or (?) if diffuse bounces are low.

In real life dulling down the reflections are usually done by adding an anti glare coating to it, this tints the facing angles of the reflections slightly green (if you wear glasses, check them out if they have such a coating).

However, for glass panes (equal thickness) using refraction is a huge waste of resources since refractions would be most evident near the edges (which you don’t see). So the trick here is to replace the refraction shader with a transparency shader. You may need to invert IOR (in the fresnel node) for backfacing faces. Unless I need to see the double reflection from multiple layers of glass (not happened so far), I’ll just use flat panes of glass.

You can actually use refraction shader on thin panes as long as you feed its normal input from Geometry/Incoming. You’d still need to invert the IOR for backfacing faces though. This trick is useful if you want frosted glass at a fraction of the price for real frosted thick glass.

Here is the setup I typically use for pretty much ALL glass I do (excluding glass vases and ornaments). If I need frosted I swap out the glass Transparency shader (I keep the shadow one) and feed it normal from Geometry/Incoming.


Thanks a ton! This was bugging me. This node setup worked like charm, albeit a bit complex.