how to make a render of a section ?

Hi all,

I have modelled a complete house, now I want to make some section views and render them. But … how can this be done in blender ?

examples:

Attachments



Note: There is a link to larger versions of the images in this post at the bottom of the post. I’m developing a related tutorial on the Blender wiki: Currently available here. / Mats

I’m just a newbie, so use this example with some care:

http://farm3.static.flickr.com/2212/2518459842_8213cba008.jpg

http://farm4.static.flickr.com/3056/2517640871_8cc625d948.jpg
Here is a simple set-up showing how to use nodes and a simple texture to get a section.

http://farm3.static.flickr.com/2207/2517640779_2284dc6507.jpghttp://farm3.static.flickr.com/2148/2517640661_2c7c459791.jpg

Settings for a simple section through x=-15.

http://farm3.static.flickr.com/2367/2518459672_1d05b35d30.jpghttp://farm3.static.flickr.com/2249/2518459738_543da06023.jpg

Section rotated 90 degrees.

Hope it helped
/ Mats

P.S.
These images are available on flickr here.

Nice trick mats !
I’ve learnt a lot with your setup, thanks !

This sure helped me out.

Thanks Mats !

Glad you found it useful.
It should be easy to combine with other materials if you put it at the top of the texture stack and use Stencil in the Map to tab. (And that’s not me saying I tried it yet.)
/ Mats

here is the nodes pic i got

which is not the same than yours

it would be easier if the nodes pic was show as follow

mind you i still have a problem because i don’t get the
out panel as your’s mine is totaly black

not certain what is going there ?

see pic

also the phrase for the cylinders shoudl say if theses cylinder are individual objects
not one object made up of 3 cylinders

Thanks

RickyBlender,
In your node set-up above, the material node has no material assigned to it. I added a note about it in the tutorial.

In the tutorial I’m working on (link), the three cylinders are separate meshes but a single object. This is not necessary of course. You can copy-rotate the first cylinder in object mode to make the cylinders separate objects. To me, keeping them a single object is a bit like using groups – it makes it easy to deal with them. If you make them separate objects there is no need to set up vertex groups. Which you choose is up to you.

/ Mats

i’m thinking more like a nooby here
because i know how difficult it is to learn blender
and a tut shuld be eays and clear to eveybody and not confusing

hope you agree with that!

you shold add a note for these cylinder to make clear you can amke it as one object with 3 mesh and 3 material with vertex group or 3 as indepedant objects and not vetex group - i think it would clearer for nooby

i corrected thematerial in node editor

now i tried to render but when i change themapp loc
i don’t see it in the rendered pic
see pic

another thing is i cannot get any shadows from cylinders if i use a lamp
i had to add a new spot light to get it
is that normal ?

not certain why the mapping is not moving the cut plane on object cube

Thanks

I added a note on the cylinders, thanks for bringing it up.

In the image above it looks like you didn’t enabled Ztransp for the cube material.

To get shadows you need to enable TraShadow for each material. It is described at the end of the tutorial.

Are you sure the node material is assigned to the cube?

/ Mats

i tried to redo the wiki example with the simple cube whic i made red

now i think i got the nodes materials ok and ztransp set for teh cube

but still it’s not working as it should
so there is still something missing but what ?
see pic

hope you can help to make this one work properly

Thanks

happy blendering

I played with this trick few years ago, but is there any way to get section fill. Like if you have concrete/ brick wall and use texture its only “crust” You can see inside place where material suppose to be. I mean section as you can see in reference image in the first post (highlighted by red color). Is there any other node trick? Thank you very much.

You could also use the Lux renderer or Yafaray, they both have architectural camera modes just for cross-sections.

@Atom: thanks, good to know.

Ok, a one way can be use via Front/Back socket of Geometry Node. For Back Material setup Shadeless. So you can get feeling of volume. For one way section its not problem choose color close to light scene. For corner section you suppose some shade :slight_smile: Any tips?

Inside .blend you can find two version of material:

  • Layer 1 - for me is better to control position of section texture by Empty so I can move and see exactly where the point is (also easy to animate) so I used Node only for Front/Back apply.
  • Layer 2 - this is Mat’s setup (sorry if I did some mistake) + Front/Back socket

animation - Section.avi

test - Section.blend
.

Attachments


Thanks vklidu, those were very useful tricks. I will have to update the wiki tutorial with your setup.

BTW: The tutorial has now been moved to → Sectioning a mesh with nodes

/Mats

:slight_smile: so with a simple Node Compositing I got shaded and textured section. I’m not so friendly with blender jet so any improvements are welcome.

The idea cames from Compositing Render Layers.

  • setup Back material of object to white (shadeless of corse as was described earlier #13)
  • setup first render layer with objects and lights
  • second render layer the same only turn off layer with lights - to get only white section part as factor for compositing
  • third render layer with section object and lights

This section object is here from three reasons:

  • filler of sections
  • coordinator for “sectioning” texture
  • easy to see place and control position of section texture

My problem are shades. When I use RayTrayce lights I got also section object shade in render. Is there option how to fix it? Thanks

Video:

Cube
http://www.mond.own.cz/blender/Section-004.avi

Blend:
http://www.mond.own.cz/blender/Section-2.blend
.

Attachments


Another idea of how to make cross-section!
Found it by mistake :slight_smile:
Here is a rough video. Works on planar sectioning only, but it uses simple node and have more control on the positioning of the plane.


Still in very early stage.
Hint: I used a plane with full mirror enabled :wink:

@vklidu : Wow, I’ve been wondering how to use composite nodes in this context. Thanks for the blend file. I never really gave composite nodes a try before, so I need to play around with them for a while.

@Syziph : Nice trick. I will have a look at it too.

you’r welcome,
There are some limits that would be nice to find a way.

  • for example if you have two crossing objects you can see outside material inside section “face” in final rendering (in Suzanne video its a part of eye (that is separated mesh) but I also hope that people interested in architecture are precise and do clean meshes :slight_smile:
    This realtively small problem can be solved by this node three http://phatcore.com/projects/Composite_Boolean.php (maybe), but since now it was very simple setup. So I dont want to do it complicated. So we will see.

  • second method (textured and shaded section via CompositeNode) - has now problem with shades. Im yet beginner and I tried to solve visible shade of “Section-Object” only by set off Ray Trace Light. So if anybody knows how to setup scene/object to get object that dont produce shade on other object will appreciate.

Thanks to get next step :slight_smile:
And sorry if my english explanation is too bad :slight_smile: Try to ask me again.

My problem are shades. When I use RayTrayce lights I got also section object shade in render. Is there option how to fix it? Thanks
Vklidu, I think the only problem is you need to enable transparent shadows for the background object/material. See attached file.

Attachments

Section-example-000.blend (114 KB)

I will check it.
In the same time I have to say not sure what I did but it works also with RayShadows
(maybe I used some experimental build by mistake). I Rendered with 2.49b and looks good.
http://www.vimeo.com/6686912
http://www.mond.own.cz/blender/Section-Ray.jpg
(Only AO ignoring material transparenci, so I turned it off for this anim)

p.s.: anim just for fun
http://www.vimeo.com/6717077
http://www.mond.own.cz/blender/Section-Ray-2.jpg
.