How to make blackface culling permanent? (Blender 2.7)

Removing blackface culling works all fine in blender, and allows both sides of my plane to display just fine… but when i upload the file to another program, one side doesn’t show right. These are supposed to be curtains, not blinds:
image

I can only figure that this is because the blackface removal didnt quite save? that its merely a display option?
What im asking is, is it blender, or the program that im uploading my file to that is removing the other side from being displayed correctly?

Yes, it is merely a display option. In 2.7, if memory serves (though it may be it doesn’t, haven’t used that in a while) it’s not even a per-material setting so there’s literally nothing to export - it’s just Blender’s viewport setting, not related in any way to your object’s data at all.

Anyway, check if “the program” has a similar setting.

The thing is, this option is not supposed to be used for really making your objects two-sided. Adding proper thickness is.

Oh alright. Thickness is the only way? i could use 2.9, and then append the file to 2.7 if there are any easy tricks besides thickness…

It’s not the only way. It’s the only proper portable way. There are certain applications where you really can’t afford the extra polygons. But that is neither here nor there. If you’re just doing some previz, make it thick watertight, even if just half a millimeter. Someone who’d end up using your model for those specific tasks will know what to do.