How to make CUDA 11.3 work with Blender 2.92 ? (Debian 10 Buster / Nvidia GPU)

Hello everyone,

On Blender 2.92, I’m trying to use Cycles renderer with a Nvidia GPU (Quadro P400)- my operating system is Debian 10 (Buster).

To install CUDA, I read NVIDIA CUDA Installation Guide for Linux (https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#introduction) using the following commands :

  1. Uninstall nvidia-cuda-toolkit and it’s dependencies : apt-get remove --auto-remove nvidia-cuda-toolkit
  2. Download installer :
    wget https://developer.download.nvidia.com/compute/cuda/11.3.0/local_installers/cuda-repo-debian10-11-3-local_11.3.0-465.19.01-1_amd64.deb ;
  3. Install repository meta-data : dpkg -i cuda-repo-debian10-11-1-local_11.1.0-455.23.05-1_amd64.deb ;
  4. Installing the CUDA public GPG key (local repo) : apt-key add /var/cuda-repo-debian10-11-3-local/7fa2af80.pub ;
  5. Enable the contrib repository : add-apt-repository contrib (NB: was already done) ;
  6. Update the Apt repository cache : apt-get update ;
  7. Install CUDA : apt-get -y install cuda ;
  8. reboot .

With nvidia-smi command I get :

±----------------------------------------------------------------------------+
| NVIDIA-SMI 465.19.01 Driver Version: 465.19.01 CUDA Version: 11.3 |
|-------------------------------±---------------------±---------------------+

Strange thing: at this moment the Blender software does not open anymore, I have to reinstall it to open it again. With Flatpak I do :

  1. Uninstall Blender → flatpak --system uninstall blender ;
  2. Install Blender 2.92 → flatpak install flathub org.blender.Blender .

Blender opens again after reinstallation. Then when I go under Edit -> Preferences -> System -> CUDA, an error message says “No compatible GPUs found for path tracing Cycles will render on the CPU” as if I had not installed any drivers or CUDA Toolkit.

I’m running out of ideas to solve my problem. Maybe someone has a clue?

Hey there! I was just struggling with a similar issue on Fedora 34. I have followed similar steps, but I confess I got frustrated and just swapped to my Solus installation to continue Blending.

That said, I have found that the appimage of Blender has always worked better for me than the universal packaging from Flatpak or Snap. Have you tried the Appimage they offer on their (Blender.org) website?

I’ll boot back into my Fedora 34 installation and see if installing CUDA worked for me and touch base again (I know it’s a different distro, but I encountered this same issue there).

Hi bhibb,

On Blender.org I only found a tar.gz file, so I went to the Appimagehub website (https://www.appimagehub.com/p/1169218/) to download appimage file of Blender 2.90.0 Beta version…

And It’s work ! When I go under Edit -> Preferences -> System -> CUDA I can select my NVIDIA Quadro P400 GPU. Thanks :slight_smile:

Have a good day

You’re so welcome! Also, that .tar.gz file IS the AppImage! If you extract that file (the .tar.gz) with archive opener (or terminal, of course), you can simply drag and drop it to disk somewhere and run the AppImage (after editing the permissions so that it can execute).

If you choose that .tar.gz option you’ll be able to get 2.92.0 :smiley:

You may try to check this: https://devtalk.blender.org/t/nvidia-prime-is-here-but-cuda-not-found/15226/27?u=woland