How to make normals continuously smooth between object duplicates?

Hello, I am not sure if this question has been asked before, but how do I get normals on a rounded mesh to continue to interpolate smoothly through a duplicate of the object in a different location?

Ok, I guess it’s better to explain it visually…:

And here it is up close, in edit mode:

These are both the same object, using the same mesh.

The normals are set to smooth.

The outer edges are not set to sharp, but changing it to sharp did nothing.

I tried extruding once to change the normals, but that didn’t resolve the issue.

I tried recalculating normals, didn’t fix it.

I want the objects to be separate, because I want to use it in a video game as a tiled asset.

Ok what you need to do is this

  1. add an array modifier
  2. select merge in the array modifier options.

simple as that
also this way you can tile your asset as much as you desire. if you want to array it both length and width just copy the array modifier and edit the number 1.000 below the “relative offset button” to zero, and set the middle set of 0.000’s to 1.000
this will place the array direction to a new axis

the merge button is the key in this.

Could copy normals from a whole object with data transfer modifier.