How to make object receive shadows, but not cast any?

Hi. I don’t know how to make object in my scene (kitchen, sun lamp, light goes through window) receive these shadows so it’s look nice, but not cast any self shadows to surroundings. I need that, so i can cut object images in photoshop and paste them in overall render in photoshop. Thanks.

If you use a lamp which can use buffer shadows you can deselect ‘Cast Buffer Shadows’ in the objects Material / Shadow settings.

i needed exact object, not all. But, figured it out. I needed to move object to another layer and in lamp shadow setting tap this layer only. Worked like a charm.