How to make particles fall from mesh

Hey guys, I’m doing this project for a client, he needs the elements to fall apart revealing an item that is inside the “bunny”. How would you approach it? Right now I`m using a hair particle to populate the mesh.

Thank you!

In the particle settings under Render choose Object. There you can use (under object; Instance Object) a previous made object as particle.
Make sure the Frame Start and End are the same so all the particles spawn at once. Under Velocity set normal to zero.
Turn gravity off under Field Weights (0)

1 Like

I think @Lump is onto something. First, I would not recommend using hair particles. There are different settings for hair particles than for a regular particle system, and going with hair seems like you’d be limiting yourself creatively (for example, as @Lump mentioned, the Velocity setting doesn’t exist for hair particles). Next, I would tweak @Lump’s recommendation so that you get a gradual reveal of the bunny (as I think spawning all the particles in frame 1 would also mean they would all fall in frame 1). What I would suggest is that:

  1. You determine how long you want the elements to fall off your bunny before being fully revealed. That will tell you the number of frames you need between your Frame Start and End. If you are rendering 30fps, and you want all the particles to fall in 10 seconds, you’ll set your Frame Start to 1 and End to 300.
  2. Determine a lifetime that makes sense. If you want your elements to fall off and stop moving rather quickly, choose something rather short (like 60, i.e., 2 seconds if rendering at 30fps). Understand that once they die, they will disappear (and stop moving - see item 3 for details). If your bunny is walking on something that would make the elements need to continue their simulation for a longer time, stretch out your lifetime.
  3. Go under your Particle properties Render settings area, find the Extra settings group and expand it. Enable the Unborn and Dead checkboxes. This is the thing that I think @Lump was getting at. When you render Unborn, you will see all the particles starting at the first frame of your animation. They haven’t been born yet, but you can see them. Also, by checking the Dead checkbox, they don’t disappear when they die. I imagine that your client wants a trail of elements left on the ground as the bunny continues to walk instead of the elements simply disappearing.
  4. Set up your collision objects as needed (Bunny, floor, etc.).

Hope this helps, and it would be cool to see the final product when complete!

2 Likes

Thank you so much for replying. I was brainstorming with the client and he probably wants to change the direction. I tried using the method that you suggest and it happened to make the particles emitted right in the start and not following the movement of the bunny. Using the hair system I animated with shape keys to make them explode. After trying this I saw @Hunkadoodle message and it all made sense, I should check the Unborn and Dead. It worked for the effect. SInce we still dont have the final concept I just made the blocking of the scene, if the client keeps with the same idea Ill have to tweak a lot of things so I will wait to keep on this one.

Here are the results.

1 Like

Hey, that`s exactly what I need, just gonna have to tweak it when the client sends me the full concept of the animation, Thank you so much. Just another question, I see that the collision with the plane happens based on the origin point of the instanced mesh, is there a way to make the collision happen based on the mesh itself?

Thank you so much!

Here is what I got so far:

1 Like

I don’t know why the mesh is colliding on the origin, doesn’t seem to happen here. I think with all the options you need it is maybe an option to use the boids instead of the Newtonian Physics type. This is sort of a flock behavior. To mee it looks more controllable that way. Play with the flight speed and Air/Land personal space to tweak the behavior. If you want you can key the behavior as well. I’ll ad a blendfile.

I did not use the unborn and dead particles out of laziness btw. I do think that is a better way in this case :wink: