How to make rendering faster.

Hey guys I’m not sure if I’m right but I notice that when I render a scene first using Preview mode and then everytime I render the picture again, using Default mode, it renders much faster.

Does it work for you?

If it doesn’t, then maybe it’s just my eyes playing tricks on me.

mmm i dont think that has been happening for me… my render preview has trouble updating with particles and it still takes a while for the render so lucky you i guess

Do you mean the Shift+P Preview? I doubt that this somehow affects the overall rendertime. I can’t remember reading about that in the docs either. So I personally would say that you were tricked by your eyes but some expert may clear things up.

yeah, trick of the mind. Its never gone any faster for me(and yeah, ive checked)

Nope it does render faster :slight_smile:

I just tested it.

I rendered the cube in default, it took 5.62 seconds.

I then rendered the cube in preview, it took 1.06 seconds.

I then rendered the cube in default again, it took 1.10 seconds.

^_~

Here’s a second shot at it (hope you can read the numbers). Default start up with no changes:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/startup.png

First time render using default 800 x 600, Asp X = 100, Asp Y = 100, 100%, time take = 5:25 seconds:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/firstrender.png

Second time render using preview, 640 x 512, Asp X = 1, Asp Y = 1, 50%, time taken = 1:05 seconds:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/secondrender.png

Third time render using default, 800 x 600, Asp X = 100, Asp Y = 100, 100%, time taken = 1:12 seconds:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/thirdrender.png

:slight_smile:

Cool! I wish mine did that…

I have to try this for myself. Nope I don’t get any time increase, although I should boast that my Default Render time is 1.77 sec. already.

Well, it doesn’t really work for me. I also have to add that I was talking about the other peview render option in my first post.
Are you sure that the CPU usage was at the same level each time you tried it? Oddly enough, my rendertime using the Default mode is about 1.70 with Fields on - without Fields it is as low as 0.70. So, 5 seconds really seems to be a lot, if you ask me…

Also, I’d not see a reason why the rendering should be faster then. But on the other hand, I’m no expert on that field…

Are you actually using the “Default” on your first render -or are you just rendering using the settings as they are when you firt turn on Blender -because that could be the difference.

That is the difference :slight_smile:

Not sure why that is so too.

I changed the settings on the third render (i.e. when I click on “default” mode again) to make sure it’s the same, dimension, size (100%) and Asp X/Y as the default start up setting of Blender.

Yeah the “Default” mode button is not necessarily the same as your default settings on startup -It’s a satic set of parameters wheras you can change the default startup to whatever you want.