How to make sure Blender is using ALL the RAM?

I am brand new to Windows 7, having moved here from the Mac world, and I was wondering if there is a limit as to how much RAM the system will allow for each application, and if there’s a simple way to change this.

For instance, how do I know that Blender really is using all 4GBs of my RAM, and that it’s not limited to 2 or 3GBs?

you just have to use 64bit windows and 64bit blender.

if i remember correctly you can only use up to 3gb or so with the 32bit versions and even this needs some special settings in boot.ini and a blender build with enabled laa flag.

Well I have both of those things, so I guess that’s good news. :slight_smile:

What would happen if I had 6 or 8GBs? Would it still use all of the RAM then?

It only uses as much as it needs.

So if you have a scene open, let’s say with a character and a rig. Then it won’t use all of that RAM, because it won’t need to. But if you are baking some heavy fluid simulations, or doing some very heavy rendering then it will use ALL of the RAM it can get.

The OS will probably keep 1 or 2GB back for itself, but all of the free RAM will be used by blender IF it needs it.

You are running 64-bit Windows and 64-bit Blender, so you are sorted :slight_smile:

P.s. I’m running 6GB on Windows 7 64-bit and I haven’t ran out of RAM before, I’ve never even went over 3GB RAM usage.

If the OS keeps 1 to 2GBs back for itself, and only allows programs to access free RAM, then doesn’t that bring the amount available for blender down to 3 or 2GBs?

ok… so if I use blender 32-bit, and I’m on 64-bit windows… blender won’t use all the ram available when needed?. I use blender 2.48-64bit 99% of the time, so most of the time it’s ok, but I can’t use yafaray on it so… some times I have to go to 2.49 which is only in 32-bit

That is correct.

you can get it from graphicall in X64. here’s kai’s X64 build

thanks for the link :slight_smile:

but why didn’t it get a final release?

edit: hey wow, it’s got photon mapping, nice!. How do I use it?, the options in scene panel don’t seem to reflect in the rendering.

Btw, this really isn’t an issue unless you’re seeing practical slow downs that are caused by memory bottlenecks – which is less common than a poor processor or GPU.

I understand wanting to ‘make sure everything is as it should be’, and that you’re ‘doing everything right’. Assume everything is going ok until something is obviously not. :slight_smile: I’ve found that saves me a lot of time – time I can actually use to USE the software. :wink:

there are times when I need all the ram I can have, because I’m texture painting/cloning (from layer to layer) or using more than one object with a subsurf of 6, so it is an issue.