How to make the hair curly?


(Falgor) #1

A simple question. How does one affect the hair made with particles with textures so it becomes curly? A lot of talk about the “eight” texture channel, but my test haven’t got any results that would actually curl the hair.

My textures merely change the colour, or make slight changes, probably only to the emission time or force, but they do not change the particles’ path at all.

Like the hair in the funky hair in the orange blog.

I think they could’ve told how they did em.


(Fligh) #2

The texture in the 8th slot must be used to give a Starting Speed (row of purple buttons second from the bottom, 4th button from the left) and random, and be assigned to ‘texture "GRA"dient’ (bottom right corner).

They are using the new Particle Patch in CVS which gives more control (you can use any texture slot, set gradient dimension etc) and can be mapped to “Strand” for the visible texture.

%<


(zachboy82) #3

hey er… since we’re on the topic of particles, uh… How come sometimes when I am making hair the strand button is available for selection and sometimes its not? A few times while making hair, I have clicked every button that I think has to do with particles and the strand button never appears, but sometimes I make hair normally and its there. Is this a bug or do you have to have a specific button selected for strand to appear?

zachboy


(protocold) #4

Falgor, firstly… thanks for your article about creating hair with the new particle system, it answered some of my questions just last week (especially the “strand” map input).

I tried to emulate the orange “funky hair”, including the curliness as well, and here is my result… It seems that increasing the “tex” & “damp” settings help give you some more curliness (but check the blend file for all the properties if you wish)

Excuse the shabby lighting, and nasty brown/grey color… i was working more on getting a fuzz-ball than i was getting a pretty rendered frame:
http://blender.dougnmel.com/fuzzball.jpg

also the .blend
http://blender.dougnmel.com/orange_imitation.blend

(my apache seems to think it’s an ascii file and feeds it as such, but, if you file->save as text from firefox [and i guess optionally give it a .blend extention] it seems to open fine)… Oh and JFTR, i’m using blender 2.40 alpha.


(Vaccine0101) #5

Just wondering what are you useing to make the hair? it doesn’t look like static particals or makehair.


(protocold) #6

We’re using the new features of particles that are (partially) build into the 2.4 alpha… check out:

the orange article: http://orange.blender.org/blog/hairy-issues
and falgor’s article: http://koti.mbnet.fi/falgor/questroom/particles/


(kane) #7

they have a blend file for that pic, http://orange.blender.org/wp-content/themes/orange/images/blog/funkyhair.blend


(Fligh) #8

How come sometimes when I am making hair the strand button is available for selection and sometimes its not?

Like most things in Blender it’s Context Sensitive; it only comes on when you have a Particle Effect open on the active object.

%<


(Falgor) #9

Thanks guys :stuck_out_tongue:


(protocold) #10

hmmm, tried a build of bf-blender to see if i could style hair (using guide curves, and they are quite nifty), this build in particular (for my given rendering earlier, i used the 2.4a downloaded straight from the blender.org), and oddly…

it doesn’t curl the hair in my orange_imitation.blend… so maybe it’s changed how you achieve the curliness… will post if i make any progress


(zachboy82) #11

I do have the object selected and the object does have particles enabled. Thats why I was curious about it. You would think that if the particles are enabled and the object is active, then the strand button would always be available but sometimes its not. Weird.

zach


(protocold) #12

Ah ha, here what i had wrong! Make sure you have the correct texture channel selected in the newest blenders… circled here in yellow:

http://blender.dougnmel.com/texturechannel.jpg


(Modron) #13

another important setting to turn up when making curly hair is ‘step’.