How to make the particle shooting last longer?

I have put my emitter to follow a circular path while it shoots the particles. The problem is, the actual shooting happens too fast. I need it to shoot for at least 2 quarters of the circle path. Even if it shoots less particles.
I just don’t see what controls this :frowning:

Can someone help me with this?

Thanks in advance,


Nevermind! I simply changed the Emission “End” time from 5 to 90 :wink:
Also, under Physics, I increased the Damp to 1, this helped a lot too. As before the particles were strangely moving as if alive upon arrival to their target (using Harmonic effector). Now they arrive smoothly and don’t move much at all.

There are three variables to consider here:

  • First there are Start and End values which are frames-relative terms for when the particles are actually fired out.
  • Next is Lifetime (particle life), which is how long the particle bullets last once they leave the gun.
  • Of course, there is also Amount, which is the total number of particles / bullets you want to disperse within the action time (e.g. how many particles are created between Start and End times)

These properties are all found in the Emission area under the Particle settings tab

Dammit - you said “nevermind” while I was typing. Oh well, at least you got your solution.