How to make the render pixelated

Hi

I am trying to make a animation and I need the render to be pixelated. In the 3D view it is how I want (pixelated) but when I render all the pixels within
each object get blurred/smoothened including the people. You can find the default project here http://www.minecraftforum.net/topic/9581-minecraft-blender-rig-–-show-off-your-skins-in-style/

I am trying to edit this to create an animation and I need the render image to be almost exactly the same as the texture (a little blur is ok but not much).

Any of these are fine as I have my own with the same layout and I can fix any parts of the character texture that are white or not the right colour so all I need is how to fix the render smoothing/blur.

PLZ HELP

I am very new to blender (this is my first project) so all the details will be very helpful.

Thanks

Crizzil:confused:

I suspect this may be too blurry for the effect you are wanting, though if you want your render (the whole screen) pixelated, you could use nodes to scale the render down, then resize it back up again.


Or is it the texture on the model you want pixelated? The thread you’ve linked to seems to have already achieved that.

Another of the same idea, but this time using the Transform node which, as it turns out, can achieve the result without blurring the final product.


Lols - actually, when I’m looking at what you’re doing a bit more I think you mean that you want the texture on the character to stay pixelated but without blurring? It’s working in 3D view but not the render - right? If so, uncheck “Interpolation” which is under the “Image Sampling” section of the Textures tab. This should prevent the image texture from blurring while it resizes to your UV.

Yes you are correct that I need to uncheck Interpol under the textures tab but there isn’t a texture applied to the blocks so I can’t an if I add a texture it messes the glass in it up.:confused:
And you are correct that I need the character pixelated aswell I can’t remember if that has a texture applied to it.:confused:

Okay - I’m confused as to whether you are wanting the “render” pixelated (my first two methods) or the texture map on your character to show up as pixelated (e.g. a low-res UV map to show as large squares instead of blurring).
…it sounds (now) like you might actually be using procedural textures instead of a UV map, though the method used in the thread seems to be that they are using UV maps. One person in there even gives away their map “for free” as an image.

…perhaps you could post up a blend file or at least screenshot what you have so I can see? I don’t want to go into methods for a dozen possibilities - I need to shoot off soon (will be back later if I disappear).

Ok so what I want is an animation of the character doing some stuff in a scene that I will build out of the cubes with the texture on but the problem I am having is that I can’t get the render image/animation to make the texture on the blocks exactly as it is on the image that is applied to it (it smudges them sort of). I am at school right now but when I get back to my computer (at about 6:45)I will send you some pics but I need the render image/animation images to be like the blocks in minecraft (type in minecraft revenge on YouTube and click on the one that is a parody of ushers song), that is what I am trying to do.

Thanks for helping me out.

By the way I need the character to be like in the YouTube video aswell.

Thanks

A quick ‘n’ dirty method, if the character is fine in your 3D view would be to render by holding the [CTRL] button down and mouse-clicking the far right icon (the movie clapper board) under a 3D view. This generates a playblast of your animation where you see things as they are in the 3D view as opposed to a full render of each frame.

I’m waiting on knowing what method you are using for texturing; at the moment it could be anything from UV texture map, procedurals, vertex paint or whatever; they are all different.

ok so all i need is the rendered images to have the blocks, characters pixelated like in the real game minecraft (you can look on youtube by typing in minecraft revenge and as i said before clicking on the parody of ushers song) and that is exactly what i am trying to do (but with a different animation). the problem i am having is that i can’t get the blocks, characters to be like they are in the video (with the individual pixels and no smudge/blur/smoothing), in the 3D view when you first download the .blend file from the page i originally linked to it is exactly how i want but i can’t get it to stay like that in the render.

This is in the 3D view
http://i42.tinypic.com/vcfpt.png
This is how I want it but in the render

This is how I have it in the render
http://i43.tinypic.com/2uhrash.png
You can see the difference and thats the problem and i have no clue on how to fix it.

hope you understand now.

Thanks

Just looking at the file (and having lunch). It appears they are using UV mapping, but they have not unwrapped / assigned textures as I would expect. Instead they appear to have simply checked the “face textures” option under the material tab. I’m not sure whether this gives the flexibility you need. However, if you assign the UV layout as a texture, you get the options like the interpolation one I mentioned above.

How’s this version? click => MinecraftBody_UV02.blend (170 KB)

Edit: This newer version includes capability for alpha (transparent) textures.
click => MinecraftBody_UV03.blend (171 KB)
…I’ve also set the 3D properties so that the (now GLSL) textures don’t look blurred in the main view. Hope it’s compatible with the same settings in your system.

Ok thanks but I am at school again so can’t try it now but that sounds like it could work because I tried it in a new blender file and it worked but I couldn’t get the glass to be partially transparent like in the file I downloaded, if you could help me with this the problem could be solved.

Thanks for the help try it in 5 hours.

Please please please reply this could be the answer to my problem!!!

turn off mipmapping and interpolation in the texture tab under the image texture… this should remove any sort of blurring your getting

I was waiting on whether the file I’d made worked for your system.

Yes your version worked but the glass ins’t transparent.
http://i43.tinypic.com/1g0jg6.png
I need the glass to be transparent (the black parts to be transparent) and then all my problems will be solved i could even make my own blocks!!!
Probably anyway the doors could be a pain.

Oh, okay. I’m completely in another district now (away from home)… The face is transparent as you want right? (with the “F”). There are usually a few of settings needed in order to use trnsparency. You need to have transparency / alpha enabled, the texture needs o affect “alpha” as well as color, and beware there is Z transparency and the other kind; confusing them breaks thing. Hopefully I’ll see this later on, but let’s see how you go.

Edit: Back home now.

With the material selected (materials tab), go down to the “Transparency” area and select it (turn it on). Make sure “Z Transparency” is the method and slide the Alpha value down to 0 (zero).

Further down under the “Shadow” area, you should also select “receive transparent” otherwise the shadows will still appear to be solid cubes. This is true for any material where the shadows will fall.

thanks this did the trick!!!
Thank you!!!
Thank you!!!
Thank you!!!
Thank you!!!

Cool. :slight_smile:

There is an option if you edit your original post to set the thread as [solved]. If you do this it will help anyone else searching for similar topics.

Hi again sorry ran into one other problem probably easy to fix but i couldn’t figure it out.

http://i39.tinypic.com/2qla5uf.png

As you can see both the textures on the characters are the same.

http://i42.tinypic.com/iodn9w.png

But if i change the image to the creeper image they both change.
I need the one on the right to be like in the bottom image and the one on the left to be like the top image.
This is the last problem i will have and then it will all be ok.