how to make the shadows less harsh in render

hi i was wondering how you make the shadows less black and more realistic right now anything covered by shadow is completely black and impossible to see at all

Turn on Environmental Lighting under the ‘World’ tab. Play with ‘Energy’ and ‘Samples’ value to achieve desired effect

Here’s a simple intro to what Sielan is talking about:

And if you don’t want to use environment lighting or any other world setting?
There must be a way to achieve this in the lamp settings?

Yes there is, you can go down to the “shadow” section of your lamp. From there, you have to raise your samples above 1, and then you can change the smoothness of lighting. The higher the samples, the “cleaner” the rendering of the shadow smoothness.

In addition to changing the samples, you may want to tweak the “Soft Size” parameter.
All this assumes you’re using raytraced shadows. If you’re using buffer shadows (an option available for Spot lights) then you have lots of options for how those shadows will work. In most instances I find you can get better results with raytraced shadows, but if you know what you’re doing you can get faster results that look perfectly acceptable using buffer shadows.

what about in a game? how would i use this then (there is no environmental lighting tab in game engine)

I guess you have to bake-render and use the casted shadows as a texture on the equivalent surfaces