How to make transparent textures


(Xtra) #1

Hi folks,

I have a problem with transparent textures: I wan’t to make a scene with a planet (like 1000 others before :wink: ) and I’d like to add a cloudlayer. To do this, I made 2 spheres - one for the planet texmap, the 2nd (slightly bigger) for the clouds. My problem is, that I’m unable to make the black background of the cloud image invisible, so that I can see the planet through it. I reduced the “alpha” value in the material section down to zero (the sphere itself is invisible now) and pressed the “alpha” button on the right side. The preview on the left side shows what I expect: only the clouds are visible, the black areas are transparent now.
When I render this, I cannot see the planet.Only the clouds are visible and the background of the cloud layer depends on the background color in the world settings. A blue color gives me white clouds on blue background. When I delete the world settings, I get white clouds and a black, invisible background.
Well, it can’t be so difficult. What’s wrong here?

Regards,
Xtra


(Andy Goralczyk) #2

enable Ztransp in the material buttons… that should help.
.andy


(Xtra) #3

That’s it!
Thanks a million!

Xtra