How to merge meshes together after mirror modifier?

Hi,
I am trying to connect/merge/join whatever my model’s half part as a one solid object as you can see from the picture.

I have tried boolea but when I am using union, the half part disappears. No clue why. I have tried control + J but I think it should be one object, so that’s not the solution. I am trying to sculpt my model so i have to come up on how do I resolve this before sculpting. I am still a beginner in Blender so I am happy to receive examples or solutions on this. Thank you!

I don’t get what do you want to achieve? If you want to join both halves into one object - ctrl+j. Then you can use remove doubles operator - to merge doubled vertices.

Hi,

I think I have to merge these one mesh instead of joining them by ctrl + j to one object for sculpting. Otherwise it will “break” from the middle or from that part which is not solid mesh when doing sculpting, right?

If you have applied the mirror modifier, then select everything and remove double vertices.

1 Like

I have already applied the mirror modifier, but these are still apart from each others?

In edit mode with everything selected, mesh > cleanup > remove double should fix it.

If you’ve applied the mirror modifier but it’s “off”, I’d wager your object pivot point wasn’t directly at the centre or you have moded something. Upload the blend and people can help by checking the state of the model.

help_.blend (3.8 MB)

Here. It has multires modifier enabled as I am trying to sculpt it. Thank you in advance!

As I can see in your .blend your have two separated objects, so :

    1. Join them (select both, then CTRL+J )
    1. Edit mode, select all, remove doubles, as said before
    1. Both parts don’t seem to be perfectly mirrored. That’s why points in the middle are not “perfectly” merged. To make the remove double efficient you must increase the threshold (bottom of the “T” panel)

nevertheless, your topolgy is not perfeclty symmetric as you can see here :


So the “good” solution would be to :

    1. Erase one part
    1. Redo a mirror, but use the merge checkbox, with the correct threshold
    1. Apply the modifier (if you need to)

See you ++
Tricotou

Quickest way is to just remove doubles in edit mode, as mentioned above,

But you could also just re-add the mirror modifier and enable clipping (Merge is normally enabled by default). You should always have clipping turned on for the mirror modifier.

With clipping enabled, select the seam down the middle, and move it along X to make sure it’s all snapped correctly.

On a different note, you’re going to have problems with sculpting this as it is. Multires likes faces to be square. So you’re going to need to add a few edge loops on some of the more rectangle faces, otherwise you’ll get stretching.

is no one didnot told him about clipping ?? After selecting mirror mod. there is clipping tick in mirror mod. tab. select it and try to break it.İmpossible…

1 Like

Thank you. What clipping actually does? Must it always be enabled when using mirror mod?

Thank you for your time to check the file! :slight_smile:
Yeah that topology is not perfect because I accidentally edited it during sculpting and that’s how I found the object was in two pieces.

I try to do as you suggest and let you know how it works. Once again,Thank you for your help!

İf your half part of creature’s ready, you can enable it. Then drag your half part to other.
After this try to break it. You can’t because clipping merged from the middle line. So it merges 2 half parts and makes one object. I use it when I modelling guns or something

I am getting a lot of answers which is good. Thank you for your time on resolving this.

Hmm I think I will delete the other part and use again mirror modifier so the topology will be the same on the both sides.

Thanks for pointing out that thing on sculpting, I will fix that. So I need to add edge loops on the triangles. Let’s see… I will let you know when I have done it.

Man, sometimes I feel it’s like almost daily fighting with Blender :wink:

Thank you for your help!