How to navigate in sculpt mode?

Hi! I cant find how to locally navigate around in sculpt mode? Like navigating around last stroke or smth. It is really confusing to sculpt without this((((
please help me :frowning:

no one knows?? how you people can sculpt without it :no:

what do you mean with navigate around??

Like rotate around model,—but only around the things wich you are sculpting, not a hole model --for exaple --how to sculp on finger? I have a full body and it will rotate around body not just finger((( thats really bad if there no such function build in(

You can fudge getting local rotation (I assume you mean the same as local in zbrush) by setting rotate around selected in the user preferences and while in sculpt mode, toggle into edit mode, select a vertex, do a small rotate to fix this vertex as the pivot and then back into sculpt mode. You will now rotate around that vertex.

Press Numpad 1 (or Click View -> Front ) then leave SHIFT and Middle Mouse Button (or press on your Mousewheel that in most mouse can be “clicked” as a middle mouse button) pressed then move the view so your model finger is in the center of the screen

( if you don’t have a mouse with a middle button or clickable mousewheel, in the User Preferences, tick “Emulate Middle Mouse Button” then with ALT + Left Mouse button you’ll do the same as Middle Mouse Button)

Press Numpad 3 (or Click View -> Side ) then leave SHIFT and Middle Mouse Button (or press on your Mousewheel that in most mouse can be “clicked” as a middle mouse button) pressed then move the view so your model finger is in the center of the screen

This way now when you’ll rotate, it will rotate with that finger as the rotation center.

Now you will have the body coming in the way in some angles, so press Numpad 1 to get in front view again then press ALT+B , create a box selection only around the finger.
It will hide from view everything else (to make them re-appear,press ALT+B again)

This way you’ll rotate around your finger without a problem

Thanks Richard Marklew! This helped a lot!1 :smiley:
Robsoie your technic I am not understood— are you tring to say if I view it from 2 views --then it snaps automaticaly to that point and i can rotate around it or what?:confused:

If you move your view to focus on a specific location of your model in at least front and side, you’ll be able to rotate around it without moving out of the sculpt mode.

As it may not be clear enough, here’s an example :

I have this :
http://i.imgur.com/Y9ihzs.jpg

I want to be able to rotate around it with “2” being the focus/center of the rotation

So i bring Front View and move the view so “2” is in the center of my workspace
http://i.imgur.com/zXqqBs.jpg
Then i bring Side View and move it so “2” becomes there again the center of my workspace
http://i.imgur.com/2X3vUs.jpg

After doing that, “2” is now the center/focus of my rotation without having moved out of the sculpt mode.

Another nice way for getting a nice close view of an object is to put the cursor to the object center and then press “c” to rotate around it

I tried as you said Robsoie—it didnt work in my version of blender i have 2.58.1 r38200M …but as i can see box nr 2 is already in your rotation focus on Z axies —can you try to move the box nr1 to left more and try your technic
will it work around box nr 1 if it will be far away from other cubes? and all cubes should be as one object by the way
thanks!

Yes it works, i have done this everytime i work in Blender sculpt, object or edit mode since the last 2 years.

Even if i move every boxes on completely different axis and pull them very far from each other, as long as i center the view on the same specific cube in both Front and Side view, i will rotate around my choice of focus everytime.

this works in 2.49b up to 2.58a the same.

I don’t understand why it does not work for you if you have set your view focus on -both- front and side view.
Unless, there’s something in your user preferences that is different from mine and could prevent this method to work on your Blender.

Here’s 3 screenshots of my user preferences settings in 2.58a , see if there’s one setting you may have different in your own user prefence, maybe that’s the explanation.
http://i.imgur.com/78JvDs.jpg
(ignore the Smooth View : 0 that may be different from you, i set it up like this because i want immediate response when changing view with numpad keys, i dislike the wait time there is by default, this setting should have no impact on the view focus)
http://i.imgur.com/0G22Qs.jpg

http://i.imgur.com/9Xah1s.jpg

WOw it is working :smiley:
Thanks a lot Robsoie :RocknRoll:

it was not working because I had— Rotate around selection turned on in the user prefs :confused:

now it is working like a magic)))
thanks