How to prevent a Circular Curve-fitting arrays from overllaping

I made an array that fits around a Circular curve-fitting array and the last part overlaps with the first one

The project file:

Any help would be much appreciated :slight_smile:


your “BezierCurve” object has been scaled and you need to apply that scale before the curve+array modifiers will work correctly. select it and press Ctrl-A > Scale. scaling objects can have funny effects on certain operations, in this case it’s causing the curve modifier to act funny. after it’s scaled, select the “rivet” object and select the “fit curve” option in the array modifier. do the same thing with the “tread” object. and make sure to set the curve to the correct one. if you have issues with merging verts, set the merge limit to something really small like .00001. Hope that helps! let me know if you have any other questions.

How exactly to set merge limit? :slight_smile:

in the Array modifier panel, there’s a checkbox for Merge. When you select it, an input field below it becomes active. That’s where you specify the merge distance.

I see niow, thanks, it didn’t solve the problem though

I’ll look at the file…

I’ll look at the file…

Does the count HAVE to be 301??

You have two choices…

  • Put up with a slight imperfection in the distances of the bumps (which will be barely noticeable if you place it somewhere other than the middle of the track)

  • Drop the array count to 300 and very slightly increase the width of your object so that it closes the gap.