How to prevent the deformation of the elements of an array on a curve?

I have seen the question on the web already, but it was in 2014, maybe now something is changed.
It’s said that there was needed to workaround this…
I’ve 2.77 but I’ll download the last one anyway.

I have a wooden circular basket and I’ve put in an array my sticks to give the skeleton of the basket… Since they are oblique (the basket is smaller on the bottom), in the bottom side they are squished horizontally like to gain more space between each other… I want to avoid this simply.

Hey; have you tried a ‘simple deform’ modifier with the array mod ? Set it to bend and type in your angle. If that won’t do the trick, you can array a modified ‘Plane’, give it a ‘curve’ modifier, ‘Parent’ 1 of your ‘sticks’ to it and enable ‘dupli-face’.

Many thanks, and no simple deform still stretches the sticks… (even deactivating the curve modifier, I mean).

Your suggestion is the same workaround I’ve read on the web… So ok I’ll do it like that. :slight_smile: