How to put ColoRamp in Bump node?

Hello,
How to put ColoRamp in Bump node ?
This is the aspect of my color ramp texture that I want to “transform” into a bump map:

And this the result when I apply it as a bump:

I don’t understand at all. Why the bump node transform my coloramp to this ?
There is no gradient, just straight lines. Why ?

Try it on a sharp glossy bsdf instead. Your distance of 0.1 I’m guessing is way too high. Guessing, because I don’t know the size of your object.

1 Like

Also try fiddling with the strength value. It could be creating too high too.

1 Like

I don’t know if this is “correct by the book”, but I pretty much never adjust strength, but I will control distance by the same value that drives the generators scale using 1/n*distance - so as you you increase the scale the distance decreases and the relative distance is maintained over all scales.

Bump->diffuse is now smoothed toward the terminator, greatly helping out on the terminator shading artifact for diffuse bump, and unfortunately, diffuse bump only. A trick back in the day was to use different bump strengths for diffuse, glossy, and coatings. Since effects are better seen with sharp glossy, I suggest using that or at least Principled.

Also, I find trying to control bump gradients with color ramp to be a chore - nearly impossible to get what you expect - especially on B-spline, Ease is the better option usually. If you have a gradient and want to control it, I suggest making yourself functions like smoothstep, smootherstep, bias and gain. Map range is a must for musgrave for those, since they expect 0-1 range.

1 Like

Thanks for reply,
I 've already done some test with different value, this is an exemple with a glossy bsdf:

CarlG, thanks you, you to took the times to answer.
In your second reply, There is a lot of things I don’t understand, sorry (I don’t speak english).
I always use the english version of Blender, but you speak about terminator shading, artifact… I don’t know that…
I also don’t know how to making myself a function smoothstep. I search everything you say in google or youtube but I still don’t know what to do, sorry. Why I can’t just use the coloramp I created ? I’m sure if it was a texture map with the same aspect, it would work perfecly

you must set the distance VERY low around 0.001 or 0.0001
keep strength to 1

1 Like

thanks,
colorrampprob4
It 's smooth but it’s not the result I exepted, I have to be very precise for this shade.
If you look the first pic, it’s not very the same shape :confused:

change the distance or change the lighting. your mesh has deformation and light reacts to that.

1 Like

It’s the same. when I lowered the distance, the lines became less and less visible. I tried many value of distance, it’s still a bad bump map

Attach your scene.

Beware that there is so much bump mapping can do, bump mapping is not good with smooth transitions. if you want such result as in your screnshot, you probably will need to resort to displacement mapping in Cycles or use your texture with the displacement modifier.

1 Like

Thanks for reply,
I don’t agree with you. It is possible to have smooth transition with bump mapping.
This is an exemple with the same coloramp texture but as a texture map and it works perfectly:


BUT I have to switch sRGB to non-color, otherwise I have the same bad result I had earlier.

How can we switch the color space in Non-color like this with a ColoRamp ?

Well that still does not look like smooth transition to me, and probably that is the best the bump map node can do with that ramp setup you had in your original post. However if that look works for you you might want to try another way to map it in case there is a bug with the weave node or the bump map node. In theory they should be working in floating point space. Try disabling the color ramp and see if that does the same thing.

Like I said it is best if you attach your scene so people can test it too.

1 Like

I just tried what you said, I remove coloRamp,
and I have not the same result but I have the same problem.
The bump still to sharp.
This is my scene, thanks
tissu_test.blend (1.5 MB)

Ok, but what is the exact look that you are looking for, any image examples? What you have in the scene seems to work as expected as far as the bump map goes, especially without the ramp. The Ramp works too but as you guess the bump node and the ramp nodes are very sensitive to values which makes sense.

Here with much lower values

2 Likes

I already give an exemple but maybe that one its more clear:


My goal is to have the same bump result in procedural.
If you managed to do that, I would be very greatful

Like this?

1 Like

Thanks a lot Stan_Pancakes !
That’s what I wanted
https://youtu.be/E-WHW-QNswE?t=25

1 Like

:rofl: You’re welcome!

1 Like

I was just trying that too, instead I tested with the displacement node as bump.

The main issue I see is that we need more interpolation methods for the ramp node and better curve controls for the rgb curve node. They are very hard to control, for instance without proper spline handles or bezier nodes it is hard to control precise curvature mapping unfortunately.

2 Likes

Btw I should mention that you should check these raw renders in Photoshop after rendering these as raw .exr, because the colorspace remapping will change the perception of the ramps and such. You can actually see this effect by disabling color management in the viewport while setting the rampnodes look. Depending on the final image the difference can be very subtle or drastic

You can also try manipulating the values with trigonometric functios to remap better curvatures.