How to remove "apply rotation" or how to check object rotation at world

Hello eveyrone. I have applied “Scale and rotation” to my object. Now I am having issues that are most likely to be explained by my object being rotated in Z axis very very slightly. How can i check that object rotation in world? I have apartment house part that is supposed to connect to each other. Length is 16 meters and missalignment in the end is like 2 milimiters. Thats like 0,00x angle. Unfortunately game renders it in a way that make such mistake quite visible.
image
I have tried to fix it for few hours, but without success. Rotation is only thing that explains it imo.

I have tried ALT+R, but it does nothing to my test object rotated by 45 degrees at world… rotation is at 0, like after “apply”

Hey, If you ‘Apply’ some transform then it will have say NO rotation, but that does not mean it is NOT rotated from how it originally was when created, WHY ? because you ‘APPLIED’ something. To get it straightened out you will have to do that in ‘Edit’ mode.
And if you really want to check, put this in the python console with the object selected;
print(C.object.matrix_world.decompose())
OR
print(C.object.matrix_local.decompose())
It will tell you what you already are seeing(maybe)

I don’t know WHAT i have to in edit mode, anyway thanks for comands. Vector are 0 and 1, so it looks like that object isn’t rotated at all. Thanks.

In Edit mode you can ‘Align’ verts/edges/faces to a certain axis or object or custom transform…

where do you find the API command in 2.8 API ?

what values get printed ?
object.matrix_local.decompose()

(Vector((4.346290111541748, 12.672157287597656, 2.945544958114624)), Quaternion((1.0, 0.0, 0.0, 0.0)), Vector((1.0, 1.0, 1.0)))

thanks
happy bl