How to Remove Mirror from objects?

When I render my objects, they show a mirror on each. I try removing the mirror through mirror modifier but it doesn’t work. and using ctrl M + x/y axis…

here is what it looks like

Please help!

Thanks

Attachments


I’m not sure how you expect anyone to help when we have NO IDEA what your scene looks like.
Please ALWAYS attach or supply a link to your blend file (you can upload to http://www.pasteall.org/blend/) with all your textures packed in it (File / External Data menu) before you save it

http://www.pasteall.org/blend/31167

Thanks

Thankshttp://www.pasteall.org/blend/31167

Hmmm… I’ve read your post several times now and had a look at the file you provided, yet I am still not sure I understand what the problem is.

You refer to the mirror modifier and mirroring with CTRL-M - so I take it we’re talking about a geometry problem? But I can see no issues with mirrored geometry in your file.

Or do you refer to the cans reflecting in the surface of each other? That’s not a geometry, but a shading issue. You’re using a pure glossy shader for that label area with 0 roughness - so basically a perfect mirror material. Make that a diffuse/glossy mix or a glossy with a higher roughness and the reflection should be much less prominent.

There are a few normals issues with your mesh, though, many of them are pointing inward, especially in the caps.

This is e. g. a glossy/diffuse mix (I changed the surrounding scene a bit to give the objects something to reflect):



Thank you! love this site! lots of good stuff!

How did you get your render quality so high? what were your sub divisions numbers set to? Can you please upload the file if possible?
Also I have been looking around and cant find the “multiply” window

thanks

Bump please

The “multiply” node is the Math node, under Converters IIRC.

As for the Render Quality I would imagine he increased the number of Render Samples set in the Render properties panel.



10 is pretty low, try 100. Don’t set it too high though, or your Render will take forever…

Sorry, I didn’t notice you came back to this thread with further questions.

a)
Indeed, the “Multiply” node is a Converter > Math node. It will come in as an “Add” node by default, but you can easily choose the desired mathematical operation in the node’s dropdown menu.

b)
The image I posted was rendered with these sampling settings:


The clamping was my “lazy” fix for some firefly issues.

c)
My subsurf settings are the same as yours. I just took care of some normals issues (as mentioned in my last post), refined the geometry a bit (an additional edge loop here and there to avoid pinching) and added a solidify modifier to give the cans and caps some thickness.

d)
Here’s the file. I had to replace the environment HDR, though, as I am not at liberty of sharing the commercial one I used for my last render. And I removed the checkerboard texture from the floor:


If you don’t render on the GPU, you might want to change the tiles’ size to something smaller (like 64 x 64 or so):


Thank you for the help,

I was almost there, I had my render and preview set to 100. Then moved my render to 200 and it was still not right. Didn’t even try to go as high as 500! Thought something else was the problem. Making my CPU work hard for an one image :stuck_out_tongue:

Thanks