How to remove noise from render image

Hi Everyone,
I have render image using the cycle render and used the denoise in the composite node and its removed the noise from the render but once i saved the image in png then i can see the noise in the output image. can you please suggest how could i remove the noise in png image as well.

Welcome to the BlenderArtists community!

I don’t know what version of blender you are using but I am assuming that you are using 2.9 and up.

The way that works best for me in reducing/removing noise all together is under the Render Properties > Sampling > Denoise. This is another way to denoise your project.

Here I am providing a comparision between the Denoise Option and the Denoise in the compositor:

Each Image is Rendered with 10 samples:

Denoise Option In Render Settings:


Render Result at 1920x1080p:

Denoise In the Compositor:


Compositor Denoise Render Result:

What I can conclude with this is that the result is almost the same. Except the compositor took around 10 seconds longer than the Render Settings Denoise Option.

What your problem may be: Is (a) if you rendered out your project at aspect ratio lower than 100%, or (b) rendered it at a lower resolution than your monitor. This is because your taking lower quality image and scaling it up to fit your screen (assuming that you viewed your output file in full screen).

1 Like

Maybe you have save the wrong layer.

1 Like

Thanks this solution works fine.