how to remove the black lines

so i selec the side and mark seam and then i select all and then i select unwrap smart uv and bake texture and i get those black lines how do i remove em easy! kinda new to blender


You are in edit mode so are those lines on the texture or you are just seeing the mesh and thinking the lines are on the texture.
If you don’t want to see the mesh then go into object mode

For further help then please ALWAYS supply a link to a demo blend file and any appropriate textures etc

its the lines when i unwrap my texture and i want to remove em

Well, I assume the lines are there because you made the uv template a part of the texture. If so, there’s no reason or need to do that. Gimp or photoshop has layers. You would save the uv template and use it as a layer in an image. Under that you can then have the actual texture. Colour and shading if it’s just a diffuse.

But you turn off the visibility of the Uv template when saving the texture file.

As it is now, you’ll just have to either paint it out or start again.

Unwrapping something doesn’t generate a texture. That’s something you apply.

As Richard has said a few times in other threads, a blend file would really help other people to help you. :slight_smile:

problem is my color is material and i bake it as texture budt when i turn of the texture you say in photoshop my color also disaper

Ok. English is obviously not your native language. So without any files to look at, some confusion is bound to happen. :slight_smile:

Could you explain clearly what exactly you’re trying to do?

i want to remove the black lines as you see on the picture i bake the uv as a texture and remove the lines as you say budt then there is noting thats the uv im using as you can see black stripes


Ok. You don’t need to bake anything if you’re just trying to get a UV template. Just use the export UV layout option in the UV image editor. This gives you the “wires” you can use as a template/guide for creating a diffuse map. If that’s what you want to do.

You could also paint directly onto the model if you want to.


i use materials and export it and i want to remove those black lines you see in the picture budt if i turn em off the grey color also disapere

When you unwrap your object, make sure your island margin is bigger then 0 as well.

how do i do that ???

It’s available on the left bar of the viewport, on the toolshelf, after you unwrap the mesh.

If you make the margin too small the colour will bleed from one section into the other. Which is not good.

I don’t see what the problem is. You only have flat colours. Create a new texture, with the colours you want. Save the texture as a file. Then export the UV layout to a separate file.

I have a question for you. How did the uvs become a part of the texture in the first place?

i go into front view select the c cursor and select all the front and mark seam press a to select all and smart uv wrap is there a way to export the image witout the uv lines

Textures don’t get saved with the UVs integrated into the image.

You don’t need to mark seams if you are going to use smart uv project. Which I wouldn’t recommend anyway. If you mark the seams manually, then use “UNWRAP”.

At the moment a combination of language and a lack of experience is making communications a bit difficult.

If you provide the blend file, things would go a lot faster. :slight_smile:

i unwrap my model when i bake the texture and get this picture i have my materials and assign the color to the vertex groups when i export it i get that image and i open it in photoshop and make the background black and move the layer down and then i have those stripes if i disable the first layer the grey color also disapere


Ok. If you don’t want to post the blend file on the public forum, then send it to me via PM and I’ll have a look at it. :slight_smile:

fine here it is


123123123123213.blend (538 KB)

Here - I just pressed bake and it worked.

No idea why yours had black lines. weird

Your bake didn’t even seem to produce any edge padding either? and the colors look different to the result of my bake

Yeah. Same result here. So you were baking the material colours to a texture. I’d suggest a bit of clean up with the geometry. There’s a lot of ngons that could cause you issues when you unwrap. Or if you were to export.

I did a quick unwrap to suggest an alternative uv layout, if you want to have a look at it.


Knife.blend (545 KB)

hey when you baked the material which options was it on also the lines where disaperd how also how did you export it so the lines isnt there