How to render a photorealistic golden ring (Cycles)

Hi all,

I want to render a photorealistic golden ring, and in the material preview (I’m using Cycles & Blender 2.83 on Ubuntu 20.04) the ring looks good, whereas in the rendered view I am getting artifacts. Plus, the golden texture doesn’t look so good. My question: Is there a way to set Blender up so that the render looks as in the material preview? I really like that golden texture with all the reflections.

Link to the .blend file: https://bit.ly/3fPNlen

TIA,

Claus

P. S.: I am attaching both the material preview as well as the rendered output. The artifacts are marked red.

a) Material preview:

b) Rendered preview:

ring_susanne

It looks like your ring has low subdivison.just add a subdivision modifer with maybe lvl 3.and in object mode right click the model -shade smooth.and load the same HDRI as in pic 1,for same reflections.

Yes? When I add a subdivision modifier, the render looks like this:

ring_susanne_01d

Are your normals all correct?

Apart from the subdivision thing: Material preview uses a built-in HDRI and doesn’t have screen space reflections turned on. Cycles uses whatever HDRI you have selected and additionally you are mainly going to be seeing the reflection of the white plane object in most of the ring due to the angle the camera is at. Try a range of other HDRI that don’t have the same harsh outdoor lighting and perhaps try different colours for the plane, including black.

You’d also get a nicer gold material if you used the Principled BSDF for the material with metallic set to 1.0

1 Like

I don 't know. I still don’t fully understand what normals are there for. When they are displayed, they are those blue lines, right? I searched for an option ‘show normals’, but couldn’t find one. As far as I understand, they should all point in one direction.

Claus

I did that, but I am still getting those artifacts. :frowning: I also used different colors, including black, but to no avail.

your last render (with subdivision) looks correct.
Keep in mind that objects like that is a pure mirror. So it’s look 100% depend on what is around.

Look what people do to create proper reflections - they create special lighting environment to be reflected and “sell” the shape:

sorry, last video is in Russian (no subtitles) but I think there are a lot of similar content in English around

I don 't know. I still don’t fully understand what normals are there for

Normals define which direction a face is facing in 3D space. In the instance of smoothing, imagine you have 3 pieces of paper, each with a 0 on the left side and a 1 on the right side (this is not precisely how this works. It is just a loose example.) Now you put them together so they read 010101. Call these your coordinates for each “face.” The engine then looks at those coordinates and their position in space to say, oh, this 01 and 0 are connectd and are greater than a certain angle, we should blend those! (again, not a scientific explanation. I would be writing paragraphs) but if you flip the middle piece of paper over, it will read 011001… the computer now says that the middle face is going the other way and your shading will be broken or have artifacts at least.

To fix this go into edit mode and select the problem mesh and do Shift+n. This will “recalculate” your normals and bring them back so they face world space. If you select invert they will be facing backwards. This is used more frequently for rendering when you may beed to define the interior of a volume.

I did this, and now my normals look like this:

To me as a beginner, it looks ok. The normals point in one direction. Still, the artifacts are there. :frowning:

Claus

Your normals look good. But the problems aren’t the normals. I hust realized that the white thing under the ring is a plate and not just a white background. The black parts and the jagged look come from low/no subdivisions. And then the white ground gets reflected. I would just leave the background transparent and use compositing to create a background.


like that?I have applyed a subdiv modifier lvl3 and weighted normal then deaktivated the planes and in the world backround i deaktivated the backround as visible.in compositing you could mask the black and change it to white,whatever you want.

Exactly. That looks really great! :wink: I made some modifications myself: I got rid of the two planes, added a subsurf modifier (3/3), and added another HDRI texture. The result:

ring_susanne_01e

One question: How did you apply the environment texture? That looks really cool.

Thanks,

Claus

Where did you do that? I couldn’t find an option. :frowning:

Claus

P. S.: I found a solution for removing the background. I selected PNG as the file format, selected RGBA, and then went to ‘Scene > Film’ where I checked ‘transparent’. Now I have the ring with a transparent background. Thanks to all who responded to my post. :wink:

visi
world tab,then ray visibility and deaktivate camera

There’s also this way

1 Like

Since you’re just starting out, I will try and take a look and throw in a few examples of some hard surface modeling tips you can use soon. You may want to try auto smooth also. I think it’s located in the object panel. I just enable it from hard ops but It’s buried in the normal menus somewhere. Auto smooth can be a lifesaver because in all actuality, unless your 3-D printing it, the model probably doesn’t need three levels of subdivisions. That might be a little bit excessive (emphasis on might). I mean, if auto smooth doesn’t resolve the issue then yeah, but, generally speaking that is probably a bit much. I usually try to stay at 2 or below unless I am doing an extreme close up or rendering hyper realism but for that I have been turned onto adaptive sampling. I could be wrong but unless you render this at poster size resolution I don’t think you are going to notice an overwhelming difference out side of render times.

P. S.: Although I tried, I still couldn’t achieve the look you got. I like it much better than my attempt. What did you use for a HDRI?

Claus