How to render an image with Alpha Channel?


(grumbel) #1

I managed to render images with an transparent alpha channel a while back, basically by turning on the RGBA button in the render screen and switching to a format that supports an alpha channel (TGA). But with blender 2.23 it no longer seems to work, the rendered images don’t contain an alpha channel, just the normal black background.

Anything I am doing wrong or is this a bug?


(theeth) #2

in the Display settings window, at the bottom, do NOT use Sky, use Remul or the other one.

Martin


(grumbel) #3

Ah, ok this seems to work. My problem was not only the Sky option, but also Gimp’s lack of support for the tga format that blender creates. While Gimp doesn’t show the alpha channel of blenders tga’s, Imagemagick does show the alpha-channel and allows to convert it to png or something else which gimp than can also handle. So I have to insert an extra ‘convert tga -> png’ step in my image creation, but I guess I can live with that. Many thanks.