how to render shadows

If I set the alpha to 0, no shadows show, i use env, no shadows, z transparency, no shadows. ive got receive shadows on. what the correct set up?

currently i need at least 100 alpha value to see shadow, but the plane reflects the light making it visible. goal is to render object with shadow on transparent background using invisible plain.

Select ‘Shadows Only’ in the shadows settings for the plane material
Blender 2.54

Thank you!

@Richard Marklew

You saved me! Thank you very much!