how to save a mesh set as "smooth" as a smooth stl for 3d printing?? or simpe remesh?

i have a mesh that looks as i want it, when it is set to smooth in object mode. however whenever i save the file as a .stl the file reverts back to its bad resolution un-smoothed version, is there a way to save it as i see it, or to re-mesh it with a simple quad mesh? i herd there was a way with rhino and t-spine but my mesh is triangulated and it crashes my system… please help me. This project was supposed to be done a long time a go.

Smooth shading is purely a visual effect, it doesn’t actually make your object surface smooth. The stl file shows the real surface, if you want to printer a smoother surface you need more resolution such as adding a subdivision surface modifier. On the stl export settings you can enable apply modifiers.

thank you, but i fully understand that! but i need to save the stl to look like the smoothed image. when i subdivide the surface it does not look smooth, but covered in smaller texture! i have been trying for weeks now, but i am not a mesh modeler so im hoping there is a trick i have missed.

as you can see here, it just becomes covered in an odd ridgy texture. and the smooth function no longer creates a smooth effect…

Your mesh is not quad based, which is required for a good subdivision surface. If it is simply a grid that is triangulated, you should be able to make it quad based by simply using the triangles-to-quads command. (Go to edit mode, select all faces, and press alt-j )

Once this is all quads, you should not have all the weird pinching.


o my god! thank you so much!, you have fixed all my problems with 2 buttons…

Thanks also really helped :slight_smile: