How to smooth out topology? As texture renders with "artifacts"

Hey all,

I have a model that has a lot of lines and shadows on it which are shown when I apply a texture to it in the web. What is the way to smooth out all these edges? I have triangulated all the edges and made sure they all exist on the same Z point (which took a lot of manual labour :sweat_smile:) although it didn’t seem to fix my issue.

In the first picture, you can see the different shades of light and dark which appear on my render.

And this is a preview of the render with the artifact also incuded:

Screenshot 2020-02-10 at 10.00.09

Can you post a wireframe, also make sure you have no overlapping faces to avoid Z fighting.

Sure! Here’s a wireframe. I tried to get the best angle for the corner that is causing the most problems. I have tried my best to make sure there are no overlapping faces and I can’t spot any. Although I am kinda new to blender and 3d modelling so I might be overlooking something.

Wireframe:

Looks like the cause is the closely packed triangles, the surface might also not be perfectly flat.

The geometry is also a bit of a mess, you should try and keep your mesh all quads (faces with 4 vertices) to keep it easy to work on. You can also use Ngons on flat surfaces.

An easy way to flatten out the vertices at the front is to select them all and then press S to scale and then constraining them to an axis and scaling to 0.

I thought as much although I selected all the vertices and they are all on the same Z axis. You can see here:

I will give your other recommendations a try. I have no idea how to constraint the scaling… but I will look into it :slight_smile:

After selecting them all, Press S to scale and then press X,Y or Z to select the axis. After that press 0 and then confirm. (in your case, it would be the Y axis)

I am at work currently without Blender so i can’t show an example.

1 Like

Having all of those faces selected, do a Mesh -> Normals -> Set Face Strength -> Strong. Also do the same for the flat part of that smaller top piece. Then add a Weighted Normal modifier on the object (make sure it’s last in the modifier stack).

1 Like

No problem! Your instructions were clear enough and I managed to follow them. Thanks!

Thanks for the tip! I tried it and improved it although there are still some small artifacts coming through.

This is where I am at now. Perhaps I should just find a new model and start again?

Screenshot 2020-02-10 at 13.18.40

I ended up using a toon material, removing the point light, turning up the ambient light to 1, and now have this:

Screenshot 2020-02-11 at 15.49.13

So it looks good! And the flat look actually fits with the design. I hope to come back to this in the future to get some shine on the material but it’s probably better to start with another model.

Thanks for the help!

You still should try fix and understand the issue, it will hit you in your next mesh too. Tris and Quads together causes problems as well as poles and star verts, there is a lot of them in your screenshot, altough i can’t really see the causing ones due to the densitiy. The glas front should be perfectly flat if:

  • All of it’s verts are on the same axis
  • You activated “Shade Smooth” on the mesh
  • You activated “Auto Smooth” @ 30deg" in the mesh option
  • The full outer loop of edges is marked sharp

Simple example with creases / sharps
notch_glas_front.blend (553.7 KB)

I applied a solidy modifier before to give it some thickness. You can revert this by deleting all verts on the opposite side. Check the example with the Carpaint Matcap. It will show any shading error.

Edit: You also need to mark the new cutout topology caused by your Boolean, sharp.