How to stop curve modifier from moving object

How can I set up the curve and object before applying the curve modifier to avoid having the object move when it’s applied? I can’t figure out the rhyme or reason behind how the object moves, even after I’ve aligned their centers and applied rotations and scale.

Supply an example of what you are talking about

Here are the steps I took in the issue I’m having…
(cursor at center. All objects have scale = 1 and origins at location = 0.)

  1. Add a plane.
  2. Add a curve. Tab into edit mode, press V, make automatic so it’s straight.
  3. Add a curve modifier to the plane.
    The plane shifts to the left when the modifier is applied. What do I need to do to add a curve modifier to keep the object where it started?



Well, first off you have only added the modifier but you haven’t “applied” the modifier yet (the “apply” button). But it seems that the plane is being moved to have its origin at the start of the Bezier curve. But if you want the plane to “bend” along the curve, you have to give it some more geometry, such as subdividing it a few times. Also, it seems that you are viewing the curve from the top (or bottom?) view, so it appears as only a straight line.

I just figured out the answer…

In order to put a curve modifier on an object without initially distorting it, follow these steps:

  1. Line up the curve’s origin with the first edge of the object (ie. the object with the curve modifier on it).
  2. Make the curve line up with your object with the start point at the front edge, and the final point at the back edge. (you may want to turn off handles and normals to make it easier to view.)
  3. Make sure that the curve’s normals point away from the curve’s origin.

The should result in an undistorted object as a starting point. Then you can start modifying the curve to affect the object.


Yes. The origins need to be lined up correctly. That’s why it was “jumping” before.