How to stop the sound squealing in 3D Sound mode?

Any ideas on how to stop the squealing sound in BGE?

This happens when your speed increases. And in some cases when the camera is in front of whatever is moving?

Notice the last few seconds of the video below.

This problem is really bugging me.

Morto.

This is the doppler effect. It can be configured here:

To disable it, set doppler to zero.

The other thing you (should) do is to use real units for everything - 1 blender unit is equal to 1 meter. This way the dopper effect should be computed properly for things like vehicle engine noise.

1 Like

Thank you very much kind member! That’s perfect cheers!

Morto.