How to straight extrude in slightly off axis?

here… i want it straight, but i cant guessing it. if i use lock x/y axis, it would not straight like that. Global and local axis gives same result…

Extrude along normal might work.

If your face isn’t aligned with any global or local axis, what you could do is align the view to the face with shift 7, then choose View in the Transform Orientation options, and move on the right axis (G XX or G YY or G ZZ)

will gonna try shortly, thanks for answer!