How to update Driver Security/"Trusted Source" setting?

Following a tutorial today, one step was using the Driver “#frame” (value I entered has no quotes) to start an animation - at the Security pop-up I selected “Ignore” in order to go read the docs on the Driver subject. Thought I could just Ctrl-Z the entry out of the parameter box and come back to the Security popup when I entered “#frame” later. Should have just hit Escape btn to close the window.
But I can’t seem to get back to that Security pop up. Things I’ve tried:

  • Undoing the “#frame” entry in parameter box, then adding the value again. No popup displays.
  • Rt click on parameter > Delete Driver. Then adding again. No popup, and the value no longer works like in tutorial.
  • Rt click on parameter box > Edit Driver – the settings popup doesn’t seem to have ability to update to “Allow Execution”
  • Rt click > Open Driver Editor – same, no apparent way to get back to that decision to Allow Exec, but I could be missing something here.
  • In Preferences > Save & Load > checking the Auto Run Python Scripts box. This works for new entries I try i.e. “#test” - there is no Security prompt; however “#frame” doesn’t work, as if the Ignore decision overrides Auto Run
  • Closing Blender then deleting the files in /Users/MyUser/Library/Application Support/Blender/2.93 (Mac), removing the User Prefs file etc – this resets all Preferences but still unable to get “#frame” to work or get popup
  • Deleting the Blender/2.93 folder mentioned in prev bullet, then starting with new Blender file, as the prompt mentions the Security decision is tied to the file.
  • Reinstalling / rebooting. Starting with a new .blend file, it still won’t prompt a new Security popup when I enter “#frame
  • tried Bash find on “Blender” but couldn’t locate any other Unix dirs with Blender files.

Any advice is welcome and treasured!