How to use actions in nonlinear animation alongside non-action keyframes from dopesheet?

I made a walkcycle for a character in an animation and created an action with those keyframes. Now I want to use both the animation I made with the nonlinear animation tab alongside with non-action keyframe. I don’t want to create actions for every single animation part that is not cyclic just to fit the nonlinear animation layers.

Is there a way to mark where the action begins and where it ends?

File of my animation: https://file.io/3GIEfzOQXe8Q

When you say “tab”, do you mean you entered tweak mode on your NLA strip ? because I think that’s one thing you can do : add an action strip and then enter tweak mode on it, which lets you edit it even after you add it to the NLA. Anyway, once you add an action strip to the NLA, that’s what the object will obey, so (as far as I know) you can’t combine NLA strips with “regular” actions (not added to NLA).

1 Like

Yes, I think so…

I see. Combining NLA strips with unassigned keyframes (unassigned keyframes to an action that would became a strip for the object in NLA) is exactly what I wanted. I made a walkcycle action and made NLA strips to the character object for a scene where it walks until it faces a ball. Then I started keyframing its leg in the dopesheet to animate a kick and realized keying in the dopesheet was ignoring the action strips I made for the character.

If this is how NLA works I’ll have to make all the animation into action parts and join them as strips… I think having to make the whole animation in NLA even the non-cyclic parts kinda lose this tool’s purpose

To my knowledge, there’s not really any such thing as keyframes outside of an action. Even if you delete an action and create new keyframes with the “new action” button still showing, the instant you hit play, it’ll turn those keyframes into an action (and autoname it.)

However, your currently selected action (in the action editor) gets a reserved place in the NLA, above the NLA strips. This action will blend just like NLA strips, although its position cannot be changed, and its influence cannot be animated. You can set the influence, blending mode in the sidebar/edited action, which is the same as NLA settings in sidebar/strip.

(Your file link gives me a 404.)

I think I understand… Thank you

I uploaded again.

https://pasteall.org/blend/214723121fec455b8a8d25854b593bce

In that file, you’re basically already doing that:

  1. You have 3 actions, on 3 NLA strips, although one of the NLA strips is disabled.
  2. You’re currently editing “ArmatureAction”, which isn’t on any NLA strip, which has keyframes for Master, Head, and Body.
  3. Since ArmatureAction is on Replace, 1.0 (as seen on the sidebar), it is replacing all keyframes from all NLA strips for Master, Head, and Body (the three keyframed bones in the action.)
1 Like

I see. Changing the blending mode to “Combine” instead of Replace in the sidebar solved all my problems!

Thanks @bandages and @Hadriscus, you mad eme understand NLA and actions a bit better =)