How to use alpha textures in yafaray ?

Hi , i tried to use them just like n blender but i get a white material .

what do i need to do to use alpha textures in yafaray ?

Have you read this? -
In case you already have – perhaps it’s this: supported image formats are - jpeg, png, tga, exr, hdr.
Hope this helps. :wink:

If a texture with alpha data is used (RGBA) and you want to render alpha as transparent (white otherwise), enable UseAlpha button [7] in the Blender Texture buttons (F6). The alpha channel will be rendered transparent and the underlying diffuse color [1] will be seen.

thanx , i had to enable the invert alpha button , dont know why. anyway now it works.

but , it now casts shadows as if it was a plane , and it actually is a plane ,but i want it to cast the shadows of the actuall alpha’d image.

if this is nt posible , is there at least a way to make it not cast shadows ?

thanx !

You have to enable “Transparent Shadows” in the render settings of Yafaray to have shadows casted by your texture.

great thanx!