How to use AutoCAD file in Blender?


(rex) #1

I try to save AutoCAD file as DXF, but some of the object was gone.
I also try to export them as .3ds, but when I import them in Blender, it will show me error message.
Does someone could teach me that Blender how to communicate with AutoCAD?

Thand you!


(Alvaro) #2

if you want to export 2D cad, use DXF ACAD version 12, but only simple entities are accepted as lines, points and circles. If your file is big, try several DXF files, Blender will import all of them respecting global coordinates.

make use of Autocad grid, then your objects will be placed in Blender grid when imported

if blender can’t directly open a 3DS file, try to open it first with Wings 3D, then export to Blender by a compatible format.

Use 3DS for 3D cad.


(Ubuntuist) #3

Did you know that Open Office Draw can open dxf-files? From there you can export to svg. You can open svg in Inkscape and export that to plain svg and import that to Blender (huh, long one).
I tested this just shortly but it seems to work. In OpenOffice you can choose Modify -> break. After that you can export just parts of the drawings.


(Blend) #4

You must change a word in the file “3ds_import.py”
Open it and go to the row 203
Write “except ValueError:” instead of “except AttributeError:”

…Save… :smiley: …and it should work… :slight_smile:

more info: http://www.blender3d.com/forum/viewtopic.php?p=49348&sid=8260e9190e6bb9c9b0137133358ae177


(greg57) #5

Hello,
tried it but it doesn’t work. I get the following:

Importing “/Volumes/Macintosh HD/Users/IO/Documents/Blender/GREGORY_3D2.3ds”
Non-Fatal Error: Version greater than 3, may not load correctly: 50331648
Traceback (most recent call last):
File “<string>”, line 646, in my_callback
File “<string>”, line 634, in load_3ds
File “<string>”, line 603, in process_main_chunk
File “<string>”, line 279, in process_object_block
struct.error: unpack str size does not match format


(Blend) #6

mmmh…
It isn’t the same error…

try
http://www.blenderwars.com/phpBB2/viewtopic.php?p=30062&sid=4c31db7214082d87d2e23c78432a0303

or with another script (import 3ds) which is at
http://www.teppisti.it/spazio/thera/
(on the left: P1: Plug-in for blender v1.0 (Python))

(and sorry for my bad english) :rolleyes:


(jasonmanning) #7

Thanks Blend, I had the same problem but now is working :slight_smile: