How to use SPE in Blender2.6?

Hi all,
I download and install these following packages:
-blender2.6
-SPE-0.8.4.f,
-python2.4
Then I follow this tutorial (http://wiki.blender.org/index.php/Doc:2.4/Tutorials/Extensions/Python/Editors/SPE),
but when I open C:\Python24\Lib\site-packages_spe\spe.blend, and run the script:


import sys
if sys.modules.has_key('_spe.SPE'):
  reload(sys.modules.get('_spe.SPE'))
else:  
  import _spe.SPE

The SPE can’t be launched at all, and the blender console window says:
read blend: C:\Python24\Lib\site-packages_spe\spe.blend
Traceback (most recent call last):
File “C:\Python24\Lib\site-packages_spe\spe.blend\SPE editor”, line 13, in <module>
AttributeError: ‘dict’ object has no attribute ‘has_key’

I guess that the python API of blender2.4 is different from blender2.6. If it is true, how to adapt this script for blender2.6?

Thanks.