How to use the plugins?


(Jolly Gnome) #1

The topic pretty much says it… I’ve got python 2.0.1 installed, and I tried the RipString’s Grass-thingy, but it didn’t do anything, absolutely anything (instructions were “press alt-p in this window and the script runs”)


(Schlops) #2

Take a look in the DOS-Window that opens when you start blender (or terminal if u r using Linux), are there any (error)-messages??


(Jolly Gnome) #3

Nope, no errors


(Schlops) #4

Ok, next question: What machine do you use??? (We need INFORMATION, we are no clairvoyants ;):o)) On “slow” machines some scripts (especially generating-scripts) can run for a looooooooooooooong time, and I mean really loooooooooooooooooooooooooooooong. So wait a little bit and see what happens. Maybe start a system-monitor to see e.g. the CPU-load, to controll that blender is still working.


(Jolly Gnome) #5

AMD k6-II 500mHz with Asus v7100 32mb display driver (geforce… 2 I think).
Process management doesn’t show anything even remotely related to that, and there’s no spike in cpu-usage when I press the alt-p. Blender (or anything else for that matter) doesn’t react in ANY way to alt-p…
Is there anyway for me to check if the Python even works at all?


(theeth) #6

This might sound stupid (or insulting to your intelligence), so, sorry in advance

When you pressed Alt-P, did you put the mouse over the text window?

Martin


(Jolly Gnome) #7

:smiley: No sweat :smiley:
Yes, I did :slight_smile:


(theeth) #8

some people have so much thin skin you have to watch out for what you say…

anyway, back to the subject: did you had a mesh selected when running the script? That’s about the only error that’s left out I think.

Martin


(Jolly Gnome) #9

Yep. I tested the grass3.blend straight out, without changing anything, and the mesh was selected. Do you know any means of testing the Python that it even works at all?


(theeth) #10

If you did everything like you say and nothing works (not even an error message in the console), than there must be something else (like a paranormal phenomenon)…

Are you using Blender Creator 2.23 or what?

Martin


(Jolly Gnome) #11

That very thing… I tried on 2.22 too but no help


(Schlops) #12

Hm, I’ve got v 1.0.2 here, it runs just fine under Windows98, blender 2.23.


(Jolly Gnome) #13

One thing I forgot to mention, is that I’m using Red Hat 7.2, and I had to compile the Python


(Schlops) #14

And you get no error msg? IIRC there are some problems with Linux & Python & blender concerning some Python modules (whrandom). The grass-generator uses a randomizer function, so you should at least get some errors. I think, eeshlo knows how to fix this problem, but first do a search on the forum, if this has been answered already.


(Jolly Gnome) #15

my problem is, that I don’t get ANY response when I try the script, not to blender, not to konsole, the cpu-meter doesn’t react to it even with a small “tik”…
I don’t know if the Python itself is working, and I’d appreciate if someone could tell me how I can simply test it?


(theeth) #16

click the “-” at the bottom of the text window and select “add new”

then type:


import sys
print sys.path

import Blender
print dir(Blender)

then, press Alt-P

Martin


(Jolly Gnome) #17

Nothing happens… absolutely nothing…


(theeth) #18

did you try alt-p with the two alt buttons?

Martin


(Jolly Gnome) #19

errrrr… what? You mean did I try it with both “alt” and “alt gr”? if so, yes, and with ctrl-alt-p, shit-alt-p, ctrl-shift-alt-p…


(theeth) #20

I hereby declare you doomed and beyond all solution

:frowning:

Martin