i was wandering…like how to activate a script on an object :expressionless: i coulnd find that

Depends which script. If it runs from the script window it should have a button (which you maybe can’t see because the window is too small). If you run it from the Text Editor window, then put yout mouse cursor in that window and hit Alt-P.


its a grass generator, and at the script window its loaded, when i click ‘make grass’ is says it can’t and i have to check the console, it says there are probs in the script. something with seeding…

Are you talking about ?

We would have to see the error message from the Console to be of any help to you. If you’re on a Mac or Linux you start a console from “Applications”. On windoze it’s already open behind Blender. Just rightclick in the header, select all, copy and paste it into your post here.


nah the fiber thing i’m stil tring to get up and running, its from a link in someone’s sig here and then i clicked scripts there and downloaded it. i’ll try to find it back and contact him. i’m not a coding noob but he forgot to define the word ‘seed.’ i dunno how to define it into the code so i didn’t. i’ll tell him if i’m able to contact him


import Blender
from Blender import NMesh, Object
from Blender.BGL import *
from Blender.Draw import *
from string import strip
from Fiber13 import *

is bugging my computer in the fiber script! and not only in the fiber script.

That is in fact the “Fiber” script I asked about. Unfortunately it’s version 1.3 (worked way back with blender v2.23 and Python v2.0.5) and you need version 2.03 which you can get here:


err…everytime it come at ‘from string import strip’ the script stops. he can’t find it.

You might want to read my 8:48 pm post again. If you have trouble with my english say so.


Using Python version 2.3
‘import site’ failed; use -v for traceback
Traceback (most recent call last):
File “”, line 40, in ?
File “C:\Python24\LIB\”, line 83, in ?
import re as _re
File “C:\Python24\LIB\”, line 5, in ?
from sre import *
File “C:\Python24\LIB\”, line 97, in ?
import sre_compile
File “C:\Python24\LIB\”, line 13, in ?
import _sre, sys
ImportError: No module named _sre

if i run it a second time this is what i get:

Traceback (most recent call last):
File “”, line 40, in ?
ImportError: cannot import name strip

there out i concluded this was the issue:

‘from string import strip’

In addition to your script version problems, you also have this:

Using Python version 2.3

File “C:\Python24\LIB\”, line 83, in ?

It looks like you are running a Blender built with Python 2.3 against modules from Python 2.4. This does not work well.

err…i taught there wuz something to do with that…didn’t get what tough :stuck_out_tongue:

woohoo, this is cool thank you so much stiv and fligh