Howcome texture like this makes this kind of bump (nor) map?

I have a voronoi texture that looks like the cap #1 in the texture editor window - exactly what I want, a few small bumps here and there on a smooth surf.

Once applied to the nor channel on a material (cap #2) the texture reveals a new side - now it seems its like the raging waves of the sea or something!!

Thats crappy!

Scaling doesn’t effect the normal map! Why not??! I cannot expect to produce the full range of materials and their bumps with this. Cant at the moment think how to go around it, either (ie. how to get few small pits here and there in the normal map).

Can somebody please point me the logic in this, or could somebody point me to whom can I present this bug?

Attachments



Oh and more words about materials/textures in Blender 2.42a… Actually I guess its a Wish List.

Note: With all the respect to developers! I kiss you! :slight_smile: smack But it could be better and so I present my simple-to-imple -ideas.

  • If only there was a wave-texture -type. You know, a simple checkboard texture deformed with 1 or more waves (adjustable number) along the Y and/or X axes. You could have square, triangular or sine waves. Makes for very nice and quick textures (to demo what I mean, make a checkerboard in Photoshop, and apply a ‘wave’-effect to it (under ‘distortion’)).

  • If only there was a ‘Randomize Material’ and ‘Randomize Texture’ functions. These would create a random material with conservative random color/nor/etc values, and a random texture with random values, respectively.

If you set the I scale to 1 and keep the intensity and contrast in the color buttons at one and use a colorband to get that you should be able to get the bump the way you want.

Can you show me how, or are you simply guessing?

Cause IMHO what I explain above is impossible to achieve in Blender at the moment with procedural textures…

…since the iScale does not effect the texture-output into the normal, you cant have a surface with rare tiny round pit/hole here and there. Note that I have been using Blender for a short time only, but I tried few dozen things already and nothing (short of image texture) works. (I want procedural because the surface is going to be huge and I want it to look perfectly randomly pitted)

  • If only there was a wave-texture -type. You know, a simple checkboard texture deformed with 1 or more waves (adjustable number) along the Y and/or X axes. You could have square, triangular or sine waves. Makes for very nice and quick textures (to demo what I mean, make a checkerboard in Photoshop, and apply a ‘wave’-effect to it (under ‘distortion’)).
    You can do this with Wood texture. Hint: Use two wood textures so that one is mapped on XXZ and other on YYZ. I got results with Difference mapping on each but I guess this is easier and more controllable with material nodes.
  • If only there was a ‘Randomize Material’ and ‘Randomize Texture’ functions. These would create a random material with conservative random color/nor/etc values, and a random texture with random values, respectively.

http://blenderartists.org/forum/showthread.php?t=69905

1). Set the Iscale to 1
2). Select the colors tab
3). Set brightness and contrast, bottom sliders, to 1.
4). Click on colorband
5). Make it a black and white gradient and set the black alpha to 1
6). Move the white or black slider on both ends to increase white or black intensity
7). Set it to nor in the material buttons and it’ll be what you want.

I have done this before and it does work.

Thanks BeBraw, you rock! :cool: Very nice hairy avatar BTW!

Cyborg dRAGON - You rock too! :slight_smile: Tested and it works! For a while I was like ‘eww’ do I have to manually work all those pixels into an image or something menial like that.

dances the happy digi artiste victory dance

Again thanks for showing me a feature I hadn’t noticed before in blender!

See the new concrete texture here: http://blenderartists.org/forum/showthread.php?p=724150#post724150

…But I wonder if you can tell me why a colorband with only a little black on the very end of the colorband (the rest is alphatransp) makes these dimples (black=down, like it should IMO)…

AND pimples! White=Up, except theres no white on the colorband, only transparent black! Umm??? Where do the white spots come from? They are from the same texture and show up when NOR is enabled (like the black dimple pit holes).

I’m not sure about the pimples. I’m also not sure why you need a colorband to get precise bumps according to RGB data.

But of course having to use a colorband doesn’t really force much, if any inconvienence.

Cyborg Dragon:

AND pimples! I’m also not sure why you need a colorband to get precise bumps according to RGB data.

Me neither. I’m also not sure if you are sort of asking why am I not using some well-known alternative method or if you are sort of contemplating on blender architechture…

But if you or anyone wants to have a look, check this .blend file
http://www.4shared.com/file/4413850/18877a81/concretesmooth2.html

pikseli: blender uses whatever image you create using textures to do bump mapping when you press the nor button in the map to panel. Your original black spots on a white background is a high contrast, therefore high bump image.

The recommendations that work are ways to tone down the contrast, to get middling dark grey spots on a middling light grey background.

I did procedural freckles on skin using little veroni dots, moderated by an alpha stencil texture set to around 20%. Set the freckles to nor and you’ve got some loathsome skin disease.

blender uses whatever image you create using textures to do bump mapping when you press the nor button in the map to panel. Your original black spots on a white background is a high contrast, therefore high bump image.

I understand this. My problem was that theres both ‘positive’ AND ‘negative’ bump, when the texture used only has ‘negative’ bump (=black dots on a transparent bacground).

As I said, if you leave the Iscale, brightness, and contrast at one and use the colorband the bumpmap will be based on the RGB values.

As I said, if you leave the Iscale, brightness, and contrast at one and use the colorband the bumpmap will be based on the RGB values.

Not sure what was the problem. I got it fixed with a lot of clicking and mouse slashing. This is what works for me:

  • Texture voronoi (or noise, whatever): In preview window theres dozen black tiny dots and otherwise totally transparent texture. Colorband: position 0: RGB .3 .3 .3, A 1; Position 0.1: RGB 0 0 0, A 0 (no other positions, this looks like just a little black on the lefthand end and transparent on the remaining 95% of the colorband).
  • Brightness, contrast, iscale are 1.000
  • Map input Orco/Cube XYZ
  • Map To Nor 4.00

Result - you can see only black dots (dimples) on the cube rendered.

Nope! No it didnt work out. In a hires render I can see the bloody white speckles. Not sure if its just a scaling problem in the voronoi so that the different ‘noise layers’ are no longer matching like in the preview.