https://www.youtube.com/watch?v=0R45KcmBVDU

I currently use a GTX 1050 TI 4 GB with i5 9400f and 16 gigs of ram. My PC lags while using some features of blender (I have attached a link for the following) So what do you guys think? should I upgrade my GPU? (I am thinking of upgrading to a RTX 2060) or is it something else that needs to be upgraded? Please let me know. Thanks

I don’t think so, I’m pretty sure the problem isn’t due to your GPU. There are circumstances where Blender can become slow due to its own limitations. But to better analyze the problem you should share a problematic .blend file with packed textures for other users to analyze.
Please edit the thread title with a descriptive title of the problem.

road texture.blend (1.3 MB)
This file has the texture which is problematic.

In this case the procedural material you are using is really heavy for Eevee (Material or Rendered view). Maybe with a better GPU you will get better performance in Material/Render mode (but I’m not sure how much more it would improve). Perhaps you should contact a user with RTX 2060 to test the .blend file by measuring fps while Orbit view in Material or Rendered mode in Eevee.

If you reduce Eevee Viewport Sampling to a very low value (1 or even 5) you will have a little less lag not during orbit the view but after orbit view ends.

Usually for Eevee you will want to use bitmap textures instead of heavy procedural textures.

1 Like

Thank you very much for the help!

I have a 2070 super, no lag in Eevee.

Cycles lags like usual :stuck_out_tongue:

Great!
Just out of curiosity, if in the Output Properties tab on the right panel, you select “Frame Rate” to 60. Then Play animation. Approximately what number does it show for fps in the top left corner in viewport?

60 fps solid when playing and not moving, it dips to 47 at the lowest when orbiting and is around 55 average.

Strange thing is that turning up the samples to 1000 makes it stay at around 54-56fps, no dipping into the 40’s even when orbiting.

Edit: Okay seems zooming in does decrease fps, at 100 samples the fps drops to as low as 7 fps.


Thanks for testing.
That’s right, zom in/out should change fps (depends on how much of the viewport area the object occupies). But samples settings during animation should not influence, supposedly animation always runs at 1 sample.