i am stuck with the states

Hi all,
Oka somehow i managed a way to create a follow flag script and a follow enemy script that i took from Agoose77 in a thread a created,he actually made the follow flag script for me and then based on that script i created my own script which makes my character follow the enemy when i click on it and then attack when its near the enemy,but now i find myself stuck in the states of logic brick,i created a set of logic bricks that when the enemy s health is 0 then add an object which would be the drops,it could be a weapon for example but i set it to a cube and also end the object which is the enemy,it worked indeed however it remains the state of attack mode and i already tried setting a subtract state or a set state to the first layer but it didnt work completly ,can anyone try to fix that for me?
ill be sending the file so u guys can have an idea of what im talking about!

btw i kind of improvised the mouselook script so sometimes when u hold the left mouse button it gets different positions,so if u want to make the character follow the enemy u have to fast click on him and just a single click,its a bug that i still have to fix later!
the file is here: http://www.megaupload.com/?d=NCVL0U42

any help iks greatly appreciated!

Nvm fellas,
i already fixed it,i forgot to set the flag state back to 1 and also send another msg to the mousearrow to be shown and other msg to the targetarrow to hide it!

ok here it is the file with most of the bugs fixed including the tracking flag ,now when you hold the left button it tracks only once so if i want to hit in a diferent location you have to click again and it works the same when you click on the monster: http://www.megaupload.com/?d=CW7JTAPN
the wip is made 99% of logic bricks,ill maybe post with textures later so check it out if anyone wants to study the file!