I am the glitter sparkle fairy! (procedural textures in animation)

I’m used to mostly modeling for still scenes, never went into much animation, but this week I was sick and while I was staying home, I tried learning basic animation.
https://youtu.be/SXAH6yNZcJM
I’m sorry about the video quality, it lost a lot in the compression, but you can still see the problem: everything glitters and shifts. It’s mostly visible on shiny materials, but if you pay attention to the sky and the lava, the textures also move around following the camera.
I will be removing that climbing down camera motion and make it pan gently to the side instead, because that bumpy motion makes for too much movement on its own, but I won’t re-render yet, it’s long enough not to do lightly!
What I want to fix is the textures. You probably recognise friendly old procedural textures. They are mapped to Object. This never caused any problem in static scenes, but in this video it does not work. How do I make them stay still?

It’s significantly less sparkly now. I changed the texture mapping from Object to Generated. Still a little sparkly, but nothing like it was at first!

No blend file??? how are we supposed to know what you’ve done wrong?

Is this Cycles? It looks like low sample rate coupled with fixed seed noise…but i’m just guessing.

Thanks. Well as you saw in my original reply, the worst of it was because of the texture mapping, I’m pretty happy having found out how to do it better. For the sampling thing, I’ll try playing with it on a couple frames just to see how it behaves, but I don’t think I’ll be rendering whole videos with high sampling, I’m working on an old laptop, it’s not very fast!

Base of the mapping, object or generated, has nothing to do with it as such:

  1. Generated coords will encapsulate the object regardless of size, stretching if required. 0,0,0 being bottom left front corner (or similar extreme).
  2. Object coords will have a constant increase regardless of size, never stretching (if scale is applied). 0,0,0 being origo of object (usually creating negative coordinates).

Sometimes you want coords to scale with the mesh, use 1. Other times you want some kind of world scale (i.e. a fixed tile size) no matter the extents of the mesh, use 2.

So one default cube with generated using 1 on a checker texture, the checkers will scale and stretch depending on mesh scale. One default cube with object using 2 on a checker texture, the checkers will continue to have scale as set by the texture parameter. Manipulate the mesh, not the object.

Depending on scale of mesh, sometimes generated will be denser than object based. Sometimes vice versa. The reason for your change, is that the scale changes, but is mesh scale was as described above (opposite), it would get worse rather than better.

For hypothetical people who may have the same issue and search the thread later, especially since I may not leave the “problem” video online forever: CarlG misread the question. The texture’s stretching was not in question, in fact on a single frame render nothing seemed wrong at all, the problem was its position shifting with the camera movement. Carl’s answer is probably valid for a different problem, but this is not the one.

I wanted to let this thread die but I figured leaving it closed on that note might mislead future beginners doing a forum search.

I meant if the glittering changes because you change from object to generated, it’s because the scale and/or stretching of the texture change. Without the blend you’re leaving us guessing what could be wrong, procedural coordinates, it’s settings, or rendering settings.