I broke texture paint...

Sorry… I did mean weight painting…
Ive been doing a nice tut on character animation, when I went to weight painting it did infact start to paint… I painted the upper arm of the character with his upper arm bone selected… it went a little too close to the forarm so I ctrl-Z and now it wont paint at all… it remains blue…

Can someone please help me out here? I put alot of work into this…

Well… nevermind the god damn system errored to before I even made the head.

i know this is like way too late to help now, but in the future, you might want to look into the autosave and save version feature.that way you wont be so angry as to swear; you’ll just use some other expletive and simply open your backup.

I checked it out and i did have autosave on.
HOWEVER… i still cant weight paint my mesh… anyone know what ta do?

i think i ran into this a while back (if not it was something similar)
if i recall, basically what was happening is crtl was locking even tho it wasn’t pressed, it would act as though it was

try rotating your view and see if it zooms or pans instead
i can’t remember how to unlock it
it was either causing the bug to happen again, thru view changes using ctrl, or by just pressing ctrl again

it’s been a while since i ran into the issue
if that’s not the case try pressing esc


You might try getting out of weight paint reselecting the arm bone then selecting the mesh and then go back into weight paint . I think when you Ctrl-Z you wound up unselecting the bone you were weight painting to instead of undoing your last paint operation … I’ve noticed that the undo system is a bit quirky when in some modes (like weight paint) that allows you to have different object types selected . And I would stay away from using the undo option in weight paint just use the “subtract brush” . And oh also if you haven’t tried using the face mode in weight painting (hit “F” while in weight paint mode) try it . You make way less “mistakes” with that option .