I cannot denoise the shadow catcher

There is no way I can get rid of noise in a shadow catcher, this is the final render, I even increased the samples to 5,000. Here there are the nodes I’m using

Hi utiq,

render with Layers. And then Composite with Bilateral Blur.

Without Blur:

With Blur:

Example Scene:
Shadow-Blur.blend (1.0 MB)

The second Alpha Over Node is only for the (white) background.
Delete it and the Output is with transparent Background.

If you want the image and the shadow seperat, put an File Output Node behind the Denoiser and the Bilateral Blur.

In the Ground layer, how did you do to hide the monkey mesh and just show the shadow?

The kinked arrow.

arrow

EDIT: Rendering is happening twice even after using one/single render layer.

Please help.

When I press F12 my rendering is happening twice. Why?

Thanks in advance.

No one knows what you’ve changed.
Why didn’t you upload the *.blend with it?

This is what the normal rendering looks like.

Hi there, sorry for not uploading the blend files. Actually, the problem is solved today, actually, I disable to click on “The kinked arrow” and instead of just shadows, everything was rendering again. That was the problem.

Nice that it works again.