I can't bake a multiple material model

Hi, I’m using Blender 2.75. I want to export a model into Unity but I must bake the materials so I can export them with the model (cycles render).
I have seen guides and videos on how to do it but I keep getting the error: “No valid selected objects”.

  • I have created an image texture node for each material with the image I created for baking, and I made sure it is the active node for each one.
  • I have tried normal unwrap and smart UV project.
  • I have tried different bake types including combined, diffuse color, diffuse direct and indirect.
  • If I uncheck “Selected to active” option blender window just gets closed when I press Bake button.
  • There is one material “Emit” and the rest are diffuse.

Here is the blend file: mino.blend (1.7 MB)

Any help will be really apreciated.

Hi @Baalhug,

I’ve opened your file in b2.79 and with some changes was able to get a bake . . . .

Firstly, bear in mind that b2.75 is an old release and that may be the cause of your issues. However, that being said . . .

Because the image files for your textures were not included in the Blend, I deleted all the textures and used plain diffuse materials. I also switched to the 2nd set of UV’s
the first set seemed to be incomplete and I couldn’t find where it was being used [ possibly in a texture I disabled?]. But the 2nd one - ‘Bake’ is the one that has your entire mesh anyway.

You are correct to have only one texture image, which you’ve selected as active in each material slot that you want the bake to use.

However, you can’t use Selective to Active in this case, because you only have one mesh.
I was able to render out the diffuse channel ( note:- COLOR only):


The colours are arbritary as I had to choose something when I deleted the texture nodes [ for which I didn’t have images ].

If you load this into a new material and assign it to your character it should work - with UV mapping channel ‘Bake’.

Because you specifically say:

“If I uncheck “Selected to active” option blender window just gets closed when I press Bake button.”

this is why I think there may be an issue in b2.75.

Here’s my Blend file [ b2.79 ] mino1.blend (1.7 MB)

Unfortunately, you may not be able to open this in b2.75, [ if not, try with APPEND - if it exists in b2.75 ].

Alternatively download b2.79:- https://www.blender.org/download/previous-versions/
or b2.80.

Hope this helps,

1 Like

Thank you very much, Damian. You were right, I installed last blender version and as soon as I baked in new version, everything went OK.

I owe you

1 Like