I can't get clear shadows in cycle render, even though they show in the viewport

Shadows in my render are barely visible:


This screenshot shows the shadows clearly in the viewport:

I don’t want the shadows to be that harsh, but it would be nice to have some control. I assume it must be the result of ambient light, and turning the sun down to 0 shows there is still plenty of ambient light in the scene:

In 2.79, there was a control for ambient light:
render_blender-render_world_ambient-light_panel
For 2.8X, I saw several references to ambient occlusion so tried turning that off but it had no effect. I also saw references to ambient light from the World background, particularly if you’re using HDRI, but I’m just using a basic colour and a png image of clouds:

I tried adjusting the strength of these two but it made the sky go dark or the clouds fade.

So my question is: how can I reduce the ambient light to reveal more defined shadows? Or is ambient light not the issue - am I missing something else?

I’m only using Cycles, but my starting point is always 441 strength for the 4500K sun and 29 strength for the sky texture, using sun position addon to sync their orientation settings. Then I will tweak for sun elevation and atmospheric conditions. Then I will adjust my exposure. Finally I may switch to HDR and adjust its strength to match the exposure.

Where your ambient light is coming from is hard to tell without looking at the file. Clipped tube mapping, I don’t know what happens in the alpha or what the object it maps to looks like.

Thanks for the reply CarlG. The Sun Position add-on did help in a way, as it’s a more intuitive way of setting the sun position and rotation, so gave me confidence that at least those settings were not the problem.

Eventually, I simply replaced the sun, and everything started working as it should. Unfortunately, in doing so, I deleted the old sun, so I’m not sure if there was a setting somewhere in the sun that I’d missed, or if the file had got corrupted. A few days ago, Blender crashed several times during saves, so I think that’s possible.

I wish I’d thought to keep the original sun to probe my settings further. At least, if anybody else has the same problem, there is a fairly straight-forward solution.

By the way, CarlG, I’m confused about the 441 strength. If I push the sun strength much above 10, everything starts to look unnaturally bright. Also, the default is 1.0. Am I missing something?

Those settings will make more sense if you try the Photographer addon.
It can be Betelgeuse bright or moonlight bright. You just compensate with exposure.

Thanks again, CarlG. Fortunately, I’m not under time pressure at the moment, so I’m finding all these rabbit holes to explore quite fascinating!