I can't get the env maps working!


(banana_sock) #1

i tried using a tutorial to get a basic planar reflection, but for some reason it never works. I use a basic plane with some text over the top and the camera looking down at it. It rendered fine to start so i started the env map. I put the empty below the camera like it said, then set the env up. I did a test render and it came up black like it said, so i moved it to the second layer, told it not to render the second layer under the env map settings and tried a render. It still stays back. I downloaded the blend file and everything seems to be identical, except that mine doesn’t work…


(S68) #2

Once the envmap is computed the first time, it stays there and it stays black.

You must delete old data pressing the ‘FreeData’ button in the EnvMap Texture

Stefano


(banana_sock) #3

i tried pressing the free data button after i’d moved it to the second layer, and when i rendered, it calculated the env map again, but it still came out black. If i put a world on, it gets reflected onto the plane (i can’t really tell if its reflected properly, but it does show), but my text doesn’t appear at all.


(paradox) #4

what is in your scene besides the plane with the text on it. The env map will reflect the enviroment. When you added a world setting to the scene sounds like it was refkecting the world. If that is all that is in the scene then maybe the env map is covering up your text. Try turning down the col slider (lower right hand corner) . This will allow what is under the env map (plane with text) to show up.
Hope this helps as I am just guessing on what you said in your posts.
Paradox


(banana_sock) #5

I still can’t get it to work. I’ve uploaded the source file so see if you can figure it out.

Source File


(BgDM) #6

Your link to source file doesn’t work.

Are you sure you have the proper layer selected on the “Do Not Render Layer” option on the env map? If so, then I have no idea. Planar env maps can be a pain at times.

Get that link fixed and we will figure it out for you.

BgDM


(banana_sock) #7

okay, i figured out i can’t have them as .blend files, so just to make sure people can open it:

Ace File
Zip File
Rar File

i don’t think i really needed to do that, but i want the answer to this problem.


(S68) #8

EVIL GRIN

Go to the material Settings of your reflective plane,

pust the ‘REFL’ button placed somewhere beneath the Texture button row (It is green)

You have ‘ORCO’ pressed but for reflections you must press ‘REFL’

Stefano


(banana_sock) #9

yay, it finally works!!!
i have gone through every tutorial but none of them that i saw mentioned putting the refl button on. Well this makes me quite happy, it’s been really bugging me. Thanx a heap!